cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Flow claims success but actions grayed out and did not perform

I have two lists in separate site collections that have identical structure. When the master list is updated, I want it to update the child list, and when a new item is created in the master list, I want it to create the same item in the child list. So far, I've gotten a flow working and claiming that it's succeeding, but it's actually not. When I look at the run history, it shows that the condition was correctly met, and triggered the correct path, but the action it was supposed to take never happened. 

 

Here's the screenshots:

 

First part of Flow is looking at a list in the site collection "contenttypehub". I created a new item with the Customer name of AAAAAA.First part of Flow is looking at a list in the site collection "contenttypehub". I created a new item with the Customer name of AAAAAA.Next it looks in a list with the same structure and name in the site collection CustomerManagement, to see if the item with Title (renamed Customer as a display name) = AAAAAANext it looks in a list with the same structure and name in the site collection CustomerManagement, to see if the item with Title (renamed Customer as a display name) = AAAAAAThere isn't, because it's new, so it correctly follows the No path... but the Create Item process is grayed outThere isn't, because it's new, so it correctly follows the No path... but the Create Item process is grayed outI've seen that other people have had similar problems, but it turned out that their condition was failing. Mine seems to be meeting its condition, but just refusing to do what it's told.

 

Here's the view of the flow from the edit page:

 

When an item is created in the first list, get items from the second list where the title = "Customer" field from the first listWhen an item is created in the first list, get items from the second list where the title = "Customer" field from the first listThe condition's looking for whether there's anything in the output of the Get Items. If there isn't, because it's a new item, then we apply to each.The condition's looking for whether there's anything in the output of the Get Items. If there isn't, because it's a new item, then we apply to each.

The condition is: 

equals(length(body('Get_items')?['value']), 1) equals true, and that part seems to be working correctly.
 
When I get down to the apply to each, the only available dynamic content is "value", and then I'm pulling Customer, etc from that.
 
The only dynamic content here is "value" from Get ItemsThe only dynamic content here is "value" from Get Items
I'm... guessing that the failure here is that "value" is actually the output of the last step, the Get Items, which found nothing so of course it doesn't work, and it's confusing because the lists have identical structure and identical fields. But the thing is, the only option I'm offered is the "value" that represents the list of items from Get Items. I'm not given an option to use the values from the item I created in the beginning, even though the flow obviously knew what those values were because it correctly converted the variable for Customer to "AAAAAA". How do I get the item that was created originally to be a stored entity that I can draw from? I've tried running a "Get Item" right after the initial creation to pull back the item I just made or modified, but it doesn't then show up as an option to draw values from.
3 REPLIES 3
Highlighted
Dual Super User
Dual Super User

Re: Flow claims success but actions grayed out and did not perform

Hi @alarajrogers As you have mentioned, the Get Items list is returning null as there are no items over there. The action create item/ get item/ when an item is udpated or created gets you just one record and so that is not coming up in the apply to each. To get the componenets of the trigger or the actions I mentioned, you can initialise a string variable and when you tap into the value of the variable you will see all the components that meet the string data type. 

 

Hope this Helps!

Highlighted
New Member

Re: Flow claims success but actions grayed out and did not perform

Hi, I'm having the same issue. Can you provide an example please. My flow is set to update if the item exists and create if it doesn't. The update works without issue using the information from the trigger. Thanks in advance!

Highlighted
New Member

Re: Flow claims success but actions grayed out and did not perform

Update: Adding the Create Item directly into the If No field without using Apply to Each fixed the problem.

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (8,726)