cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PepeT
Frequent Visitor

Flow copy SharePoint List to another site - User could not be found

I'm trying to create a flow to copy a SP List to another SP List for archival purposes. Both lists are identical in the number and types of columns. One of the columns is a people column with "Allow Multiple Selection" set to yes. Columns in images below were remove for simplicity.

When I run the flow and the people column has one value, user email entered, it works fine. If the same column has more then one value, more then one email entered, it fails with the error message, "Status code 400":

"The specified user firstroom@domainName.com;pepe@domainName.com could not be found."

 

1.PNG2.PNG3.PNG

 

 
2 ACCEPTED SOLUTIONS

Accepted Solutions
v-litu-msft
Community Support
Community Support

Hi @PepeT,

 

You no need to convert the Email array variable into a string, please follow the configuration in the screenshot shows to recreate the Append to array variable action, and put the variable into the create item directly:

Annotation 2020-04-21 162228.png

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

abm
Super User
Super User

Hi @PepeT 

 

Did you clicked on the T sign

 

image.png

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials

View solution in original post

5 REPLIES 5
sudharsan1985
Solution Sage
Solution Sage

Hi @PepeT 

Try to use the below format and it should work

[
{
"Claims": "i:0#.f|membership|username@o365practice.onmicrosoft.com"
},
{
"Claims": "i:0#.f|membership|username@o365practice.onmicrosoft.com"
}
]

 

Hope it helps, please like it or mark it as a solution if it resolves ur clarification or issue
-Sudharsan K...

Hope it helps, please like it or mark it as a solution if it resolves your clarification or issue
-Sudharsan K...
v-litu-msft
Community Support
Community Support

Hi @PepeT,

 

You no need to convert the Email array variable into a string, please follow the configuration in the screenshot shows to recreate the Append to array variable action, and put the variable into the create item directly:

Annotation 2020-04-21 162228.png

 

Best Regards,
Community Support Team _ Lin Tu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Still doesn't work for me. After I insert the action "Append to Array Variable" it inserts another "Apply to Each". Then on the action to "Create Item" in SharePoint I can't see the variable.

1.PNG2.PNG

 

 

Thank you.

Pepe

abm
Super User
Super User

Hi @PepeT 

 

Did you clicked on the T sign

 

image.png

 

Thanks



Did I answer your question? Mark my post as a solution!

If you liked my response, please consider giving it a thumbs up


Proud to be a Flownaut!

Learn more from my blog
Power Automate Video Tutorials
PepeT
Frequent Visitor

That did it. This is work as I wanted.

 

Pepe

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Power Automate Designer Feedback_carousel.jpg

Help make Flow Design easier

Are you new to designing flows? What is your biggest struggle with Power Automate Designer? Help us make it more user friendly!

Top Solution Authors
Users online (1,853)