cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flow fail to update rows

Hey guys,

1 ACCEPTED SOLUTION

Accepted Solutions

Hi again

It sounds realliy weird 😞

Do keys for all failing rows have anything in common? Every single failing row has @ but the successful ones not, or they have leading or ending spaces and the others not...

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



View solution in original post

12 REPLIES 12
Anonymous
Not applicable

So, I have many flows that collects response details from forms and updates rows on an excel worksheet with submission time, everything have worked fine, but last week I added 20 more people from the same organization (total of 100 people in the worksheet now) and for some reason only like 10% of these names work in the sheet (old names still work)

 

So, when a person submits a form, response details are collected, user profile is collected and a row is updated. I have double checked the names in the domain and it is always like Lastname, First name @ CompanyName. I have checked the forms and the people have submitted the form and I'll get an error on flow that says:

"status": 404,
"message": "No row was found with Id 'Name, Name @ Company'.\r\nclientRequestId: beac05f8-3265-419a-ad21-86eef93a6769\r\nserviceRequestId: b67ca0e3-44c1-48c2-9b07-f381c236074f",
"error": {
"message": "No row was found with Id 'Name, Name @ Company'."
},
"source": "excelonline-wus.azconn-wus.p.azurewebsites.net"
}
 
These names are clearly in the table, but only a handful of these new names work? So to be clear, let say that we
have four people:
 
Ericsson, John @ Testcompany
Stevenson, Fredric @ Testcompany
Quin, Eric @ Testcompany
Jonson, Andreas @ Testcompany
 
Only John and Andreas work even though all four have submitted the form.
 
Please help, thanks!
Andreas
 

 

 

Hi

You are getting rows with 'List rows present in a table' action block, right?

If so, Are you applying any ODATA expression in Filter  Query input?

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Anonymous
Not applicable

Yea,

 

Get response details - Response ID = triggerbody() = triggerBody()?['value'][0]?['resourceData']?['responseID']

 

Br

Andreas

Hi again

Can you share a screenshot of your PA Flow in edit mode, expanding all the cards and giving details of each expression you currently use, so we can understand better the challenge?

BR



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Anonymous
Not applicable

excel.PNG

 

 

Week7.PNG

 

This morning when I sent out the link to this week form (Week 7 form) it worked for the first 3-4 people who submitted, not it doesnt work anymore. When I check the flow history it says "No row was found with Id 'Hey, Man @ Company'. even though there is a cell with that exact name. I have added my own name within the list and try and it works fine. Its like it only works occasionally

 

Anonymous
Not applicable

Ill give you an example, on the pics below you can see the name of the person in the Excel table, and the name of the same person in the "failed flow history"

 

 

 

name.PNGfailed.PNG

 

 

Hi again

It sounds realliy weird 😞

Do keys for all failing rows have anything in common? Every single failing row has @ but the successful ones not, or they have leading or ending spaces and the others not...

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Anonymous
Not applicable

That is the weird part, there really is nothing that differs between those who succeed and those who fail, there is a couple of people with @ that work, and a couple of ppl without @ that work/does not work

Anonymous
Not applicable

WTF.. seems to be a space between those that doesnt work

Anonymous
Not applicable

That might have been the problem, haha. There was a space in the end of the names on the new ones I have added, that might explain it. Ill have to wait for some more ppl to submit but hopefully that was the issue

Anonymous
Not applicable

Yup. The problem was the spaces within the Excel table. Lol. Now I works, thank you so much dude 🙂

OMG... One possible approach to avoid this problem in the feature is to either use trim() for comparations purposes or use contains() instead of equals().

Glad to hear the nightmare turned into a happy ending!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Users online (4,472)