cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Super User
Super User

Flow fails to get group members, works with many groups, but not this one.

I have many outlook groups I use in my flows.  One group is not cooperating.  I get error during the List Group Members action, 100%.

 

Unable to process template language expressions in action 'List_group_members' inputs at line '1' and column '1764': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_office365groups']['connectionId']' cannot be evaluated because property 'shared_office365groups' doesn't exist, available properties are 'shared_sharepointonline'. Please see https://aka.ms/logicexpressions for usage details.'.

 

Deciphering these messages have been quite difficult to a non-programmer as myself.  Please advise...

 

Thank you.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: Flow fails to get group members, works with many groups, but not this one.

Well, it turns out it is not as bad as when you add a people picker column, but its still not good.  I wasted half of my day to find no rational explanation.  I did a "save as" on the flow, and redirected my powerapp to the new flow, and the Get Group Members action started working.  I changed nothing else.  I wish I could bill MS back for this type of garbage.  We certainly pay them for every little detail.

View solution in original post

2 REPLIES 2
Super User
Super User

Re: Flow fails to get group members, works with many groups, but not this one.

I recreated the action.  I even used one of the groups that work in other flows.  Same error.  I'm not going to be happy if I have to recreate a flow again for yet another odd, non descript reason.  The adding a new sharepoint people picker column making ALL of my get item action fail is bad enough.

Super User
Super User

Re: Flow fails to get group members, works with many groups, but not this one.

Well, it turns out it is not as bad as when you add a people picker column, but its still not good.  I wasted half of my day to find no rational explanation.  I did a "save as" on the flow, and redirected my powerapp to the new flow, and the Get Group Members action started working.  I changed nothing else.  I wish I could bill MS back for this type of garbage.  We certainly pay them for every little detail.

View solution in original post

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Speakers, submit your sessions now! Call for speakers ends Feb. 10!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,186)