cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
martinav
Community Champion
Community Champion

Flow fails to get group members, works with many groups, but not this one.

I have many outlook groups I use in my flows.  One group is not cooperating.  I get error during the List Group Members action, 100%.

 

Unable to process template language expressions in action 'List_group_members' inputs at line '1' and column '1764': 'The template language expression 'json(decodeBase64(triggerOutputs().headers['X-MS-APIM-Tokens']))['$connections']['shared_office365groups']['connectionId']' cannot be evaluated because property 'shared_office365groups' doesn't exist, available properties are 'shared_sharepointonline'. Please see https://aka.ms/logicexpressions for usage details.'.

 

Deciphering these messages have been quite difficult to a non-programmer as myself.  Please advise...

 

Thank you.

 

1 ACCEPTED SOLUTION

Accepted Solutions
martinav
Community Champion
Community Champion

Well, it turns out it is not as bad as when you add a people picker column, but its still not good.  I wasted half of my day to find no rational explanation.  I did a "save as" on the flow, and redirected my powerapp to the new flow, and the Get Group Members action started working.  I changed nothing else.  I wish I could bill MS back for this type of garbage.  We certainly pay them for every little detail.

View solution in original post

2 REPLIES 2
martinav
Community Champion
Community Champion

I recreated the action.  I even used one of the groups that work in other flows.  Same error.  I'm not going to be happy if I have to recreate a flow again for yet another odd, non descript reason.  The adding a new sharepoint people picker column making ALL of my get item action fail is bad enough.

martinav
Community Champion
Community Champion

Well, it turns out it is not as bad as when you add a people picker column, but its still not good.  I wasted half of my day to find no rational explanation.  I did a "save as" on the flow, and redirected my powerapp to the new flow, and the Get Group Members action started working.  I changed nothing else.  I wish I could bill MS back for this type of garbage.  We certainly pay them for every little detail.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (1,654)