cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Microsoft
Microsoft

Flow forwarding flagged email loses images

I've built a fairly straight forward flow ... if an email is flagged, send an email.  The problem is all images are lost in the send ... what am I forgetting?

 

 
 

InkedAnnotation 2020-04-09 092712_LI.jpg

Original e-mail

InkedAnnotation 2020-04-09 092508_LI.jpg

Received forwarded e-mail

InkedAnnotation 2020-04-09 092556_LI.jpg

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User III
Super User III

Re: Flow forwarding flagged email loses images

hi @cumoczar1  I discover that this kind of images are included into attachments, when you forward the email manually you get this image path

 

<img data-imagetype="AttachmentByCid" originalsrc="cid:image006.png@01D60E57.62AF5650" naturalheight="0" naturalwidth="0"
src="https://attachments.office.net/owa/Christian.Abata%40cloud360.com.ec/service.svc/s/GetAttachmentThumbnail?id=AQMkADU3ZTZmOTc4L8kNAb4Z3P6snbfQ2SSfsCvzlzW-d5g&amp;animation=true" 
width="695" height="208" data-outlook-trace="F:2|T:2" style="width:7.2395in; height:2.1666in" crossorigin="use-credentials">

 

But when you see the body email  the same image code is

 

<img width="695" height="208" data-outlook-trace="F:1|T:1" src="cid:image006.png@01D60E57.62AF5650" style="width:7.2395in; height:2.1666in">

 

So, outlook in some where gets the image that is in attachment to adding into html code but PA can't do that. PA needs an email in some server to show it and are not able to get the attachment and insert it in the code.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

View solution in original post

3 REPLIES 3
Highlighted
Super User III
Super User III

Re: Flow forwarding flagged email loses images

@cumoczar1  your flow is ok, I tested the same and I suppose that is becouse the content is blocked or maeby is a client error, test it in owa version.

Could you forward me the emal to test? christian.abata@cloud360.com.ec



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
Highlighted
Super User III
Super User III

Re: Flow forwarding flagged email loses images

hi @cumoczar1  I discover that this kind of images are included into attachments, when you forward the email manually you get this image path

 

<img data-imagetype="AttachmentByCid" originalsrc="cid:image006.png@01D60E57.62AF5650" naturalheight="0" naturalwidth="0"
src="https://attachments.office.net/owa/Christian.Abata%40cloud360.com.ec/service.svc/s/GetAttachmentThumbnail?id=AQMkADU3ZTZmOTc4L8kNAb4Z3P6snbfQ2SSfsCvzlzW-d5g&amp;animation=true" 
width="695" height="208" data-outlook-trace="F:2|T:2" style="width:7.2395in; height:2.1666in" crossorigin="use-credentials">

 

But when you see the body email  the same image code is

 

<img width="695" height="208" data-outlook-trace="F:1|T:1" src="cid:image006.png@01D60E57.62AF5650" style="width:7.2395in; height:2.1666in">

 

So, outlook in some where gets the image that is in attachment to adding into html code but PA can't do that. PA needs an email in some server to show it and are not able to get the attachment and insert it in the code.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

View solution in original post

Highlighted
Microsoft
Microsoft

Re: Flow forwarding flagged email loses images

Thanks Christian - I changed the flow to forward instead of creating an email and the images appeared!  Now I'll just need to figure out how to add the attachments as forwarding in my situation won't work.

 

Thanks for looking into this and resolving!

 

-Curt

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (9,170)