cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Bruce_in_Bucks
Frequent Visitor

Flow in Teams with Adaptive Card to collect responses - Version Problem?

Hello Flow World,

 

I've built my adaptive card using https://adaptivecards.io/designer/. The default version is 1.3 but my Flow failed with the message "We're sorry, this card couldn't be displayed" (in Teams Chat). Randomly fiddled with the card designer and dropped the version to 1.2 and it works fine. However; version 1.2 does not include Required Input restrictions (Version 1.3 does) and I'd really like that. 

 

My flow in Teams will;

(1) Get Items from a Teams List called "Input" and then

(2) Post an Adaptive Card to a Teams user and wait for a response (runs with Concurrency) using the user email from Step 1 as well as other dynamic content and a url link to my company's logo for an image, then

(3) The responses from the adaptive card are captured with Create Item in a new Teams List called "Output" and, whilst it took all morning to get right, I have Expressions along with the original dynamic content.

 

It works in Version 1.2 but I'd like to get the card in 1.3 for required input rules to operate. Teams is on Office365 so it's up to date.

 

Can you help?

 

Thanks in advance,

Bruce

1 ACCEPTED SOLUTION

Accepted Solutions
annajhaveri
Super User
Super User

As far as i know currently 1.2 version of Adaptive card works with Microsoft Teams, the version 1.3 of adaptive cards doesnt work with Microsoft Teams yet.

Regards,
Anna Jhaveri

If I have answered your question, please mark the post as Solved to help other users to identify the correct answer
If you like my response, please give it a Thumbs Up.

View solution in original post

4 REPLIES 4
annajhaveri
Super User
Super User

As far as i know currently 1.2 version of Adaptive card works with Microsoft Teams, the version 1.3 of adaptive cards doesnt work with Microsoft Teams yet.

Regards,
Anna Jhaveri

If I have answered your question, please mark the post as Solved to help other users to identify the correct answer
If you like my response, please give it a Thumbs Up.

View solution in original post

Bruce_in_Bucks
Frequent Visitor

Thanks Anna, I looks like it.
365-Assist
Advocate IV
Advocate IV

Is there any news of when V1.3 will be available. I have the same issue.

RobotRising
Frequent Visitor

Would also like to know when 1.3 will be available for teams. 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Users online (2,027)