cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flow keeps failing - Parse JSON - Null Path - Attachments on Forms isn't working

Hi,  I hope someone can help me.  I have created a flow using Microsoft forms as the trigger so to speak, so when a form is submitted an item is then created in Sharepoint as a list item and it also brings over any attachments.  I thought I had solved the issue by making all of the fields on the form mandatory but sadly this hasn't been the case. 

 

"Unable to process template language expressions in action Parse_JSON' inputs at line '1' and column '2119': 'Required property 'content' expects a value but got null. Path ''.'.

 

Any ideas please? Thank you. 

 

FILE.PNGJSON.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
yashag2255
Dual Super User II
Dual Super User II

Hi @Anonymous 

 

You can check out my post here to check if the person uploaded a file or not and based on that proceed with the next steps: https://www.bythedevs.com/post/working-with-files-on-ms-forms-in-ms-power-automate

 

Video tutorial: https://www.youtube.com/watch?v=kNC8q6NzBEc

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

2 REPLIES 2
yashag2255
Dual Super User II
Dual Super User II

Hi @Anonymous 

 

You can check out my post here to check if the person uploaded a file or not and based on that proceed with the next steps: https://www.bythedevs.com/post/working-with-files-on-ms-forms-in-ms-power-automate

 

Video tutorial: https://www.youtube.com/watch?v=kNC8q6NzBEc

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

enisbaftiu
Regular Visitor

I want to have the attachments as an optional not required.

 

What do you guys recommend?

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (57,660)