cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

Flow losing/not rendering photo in email

I have created a flow triggered when an email is received. From there it looks through various contacts lists, deletes the duplicates in those lists, and then creates an array with all of those emails in it. The last step of the flow sends an email to those contacts. The body of the email being sent is the body of the email that was received and triggered the flow (using dynamic content). Unfortunately, one of the photos in that body does not render in the email sent at the end of the flow. Rather, it shows the file name in the email where the photo should be. I am having difficulties figuring out why that is/ how to fix it because there are 3 or 4 other .jpg files in the email that come out just fine.  I have tried using a different file format and no change.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User III
Super User III

Re: Flow losing/not rendering photo in email

hi @med219 this happends becouse the image needs to be in a secure server, so you can show images in HTML message uploading the image for example in blogger.

I use blogger to upload the imagen teh I get de URL and finally I use that url into a tag in html like this.

 

<img border="0" data-original-height="679" data-original-width="1535" height="141" src="https://1.bp.blogspot.com/-wD6s_GZcudw/XgtyBT_J3nI/AAAAAAAAAlg/maYfDtIKgz0WuCNGkSGWayKa4up_6RFkQCLcB..." width="320" />



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

View solution in original post

2 REPLIES 2
Highlighted
Super User III
Super User III

Re: Flow losing/not rendering photo in email

hi @med219 this happends becouse the image needs to be in a secure server, so you can show images in HTML message uploading the image for example in blogger.

I use blogger to upload the imagen teh I get de URL and finally I use that url into a tag in html like this.

 

<img border="0" data-original-height="679" data-original-width="1535" height="141" src="https://1.bp.blogspot.com/-wD6s_GZcudw/XgtyBT_J3nI/AAAAAAAAAlg/maYfDtIKgz0WuCNGkSGWayKa4up_6RFkQCLcB..." width="320" />



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

View solution in original post

Highlighted
Regular Visitor

Re: Flow losing/not rendering photo in email

Okay great thank you. I figured out how to do it, I didn't have to create the html tags because the email service provider did that for me but I was able to embed the photo using a link, as you suggested.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (5,214)