cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Sandie
Helper III
Helper III

Flow not automatically triggering from Form submit

I'm trying to create a flow that triggers automatically on form submit, but this is not working.  I have tried a couple of different forms/flows with no success.

 

Firstly I tried with a group form.  This was not in the dropdown list to select from, so I used the Form ID to select the form. This did not work.

 

I wondered if I might be doing something wrong with the ID (I don't think so, but it never hurts to check) so I created a new form in "My Forms" and a new flow to trigger this.  Again, this is not working.

 

In all cases the form responses are being collected, and I can see them in the Excel files.

 

Can anyone assist? I am not sure how to troubleshoot this?

1 ACCEPTED SOLUTION

Accepted Solutions

Hi all, 

I have made a test and the issue is solved now, please make a test again and let me know if your issue still exists.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

16 REPLIES 16
ChristianAbata
Community Champion
Community Champion

yes, I hope is a temporary issue.



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
Sandie
Helper III
Helper III

Eventually my flows did get triggered.

It seems that the trigger from Forms can take up to 90 minute to occur.  This is an ongoing issue, and as far I can tell dates back at least to 2017, if not earlier.

Makes it very difficult to learn and test by iteration as well, when you have to wait 90 min to see if what you did worked!

sure @Sandie  I know that this kind of issues are quickly solved. 



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA
nikkbic
Regular Visitor

Thanks - I'm currently having trouble and wondering why it's not working, so I'll give it some time to tick over!

I've found that once you get one triggered, you can then "Test" and use the data from the previous run to quickly iterate

v-alzhan-msft
Community Support
Community Support

Hi @Sandie ,

 

I would make a test and reply here one the issue is confirmed.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

my forms have been working for 12 months, no issues, worked Friday...not today (Monday 10th Feb)

 

created a new form and flow to test, still no go.

 

pretty poor, hope it magically gets fixed ASAP.

 

 

Anonymous
Not applicable

I'm having the same issue today on multiple forms/flows. It just fails silently as the flow is never triggered to show a failure.

correct..that's what I'm experiencing too...

 

The form itself if working as you can see submitted info has been appended via excel.

 

but flows trigger for forms submit is not working / triggering / communicating correctly.  

 

Noticed that latest forms submitted data does not get picked up in flows either when you go to run a test with previous data...last previous data it shows me was Friday when I know it was last working.

 

any tests forms I put  through today, don't even show up, so its not processing or communicating properly at all to forms.

 

 

v-alzhan-msft
Community Support
Community Support

Hi all,

 

I have made a test and the issue is confirmed on my side.

The issue has been reported to my product team, I would reply here when the issue is solved.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

 

I just had 2 (out of many) of my tests come through to my email from this morning,  so that's about a 8 hours delay

 

(the flow sends me a email and outlook task of the submitted form results)

 

just put a form through a few moments ago to see if problem is resolved (should created a email and task within a minute of submittal)

...but alas.... 

nothing....  

 

glad you have been able to reproduce the fault! 

 

Thanks, waiting in anticipation for resolution to occur

TTE
New Member

are there any updates yet?

 

form I submitted at 5:01pm, only was processed at 7:09am.  what the heck is going on!?

progress report? any news?

TTE
New Member

UPDATE:- 

 

This problem today (12/02/2020) has mysteriously fixed itself for my form submit triggers.

 

hope others are seeing the same!!

ChristianAbata
Community Champion
Community Champion

hi @TTE as I told you this kind of problesm normally are solved quickly



Did I answer your question? Please consider to Mark
my post as a solution! to guide others :winking_face:

Proud to be a Flownaut!


If you want you can follow me at www.christianabata.com Quieres contenido en español? Síguenos en Power Automate LA

Hi all, 

I have made a test and the issue is solved now, please make a test again and let me know if your issue still exists.

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

New Process Advisor Capabilities carousel.png

Read the blog for the latest news

Read the latest about new experiences and capabilities in the Power Automate product blog.

PA Survey Carousel Image.png

We want to hear from you!

If you are a small business ISV/Reseller, share your thoughts with our research team.

AI Builder AMA June 7th carousel (up on May 25th, take down June 8th) (1).png

'Ask Microsoft Anything' about AI Builder!

The AI Builder team invite you to ask questions and provide helpful answers at our next AMA.

Users online (2,120)