cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate IV
Advocate IV

Flow not getting data as expected

I have created a MS flow which will trigger email when item got added/modified in SharePoint list. Flow is triggering fine but there is strange scenario.

 

  1. I have created an item in sharepoint list through PowerApp which is approval application. 
  2. With in one minute i have approved the request by login as approver. 
  3. Flow should send two email notifications now: one is for submission for approval, second is after approval. 

But flow is not running immediately because it will trigger for every 5mins (with Office 365 plan). When flow is running it is taking latest data which is approved data. But never getting any email for submission. Is this behavior of flow application? 

 

With SP2013, Sp2010 workflows this is not the case. 

5 REPLIES 5
Highlighted
Super User II
Super User II

Re: Flow not getting data as expected

Please provide an expanded/detailed screenshot of your Flow so that we may better assist you. Thanks.

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Highlighted
Post Prodigy
Post Prodigy

Re: Flow not getting data as expected

Hello @MihirY ,

 

I surmise the problem with your flow might be your Email address is incorrect.

 

Can you share a screenshot of the configuration of your flow and the Approve action detail, please? In this way, we can provide you with more detailed and accurate solutions.

 

Best Regards,

Community Support Team _ Lin Tu

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted
Advocate IV
Advocate IV

Re: Flow not getting data as expected

Below is my flow screenshot

 

flow_screenshot.png

Highlighted
Post Prodigy
Post Prodigy

Re: Flow not getting data as expected

Hi @MihirY ,

 

You can add this branch to prevent you from being prompted after no case contains a matching value.Annotation 2019-05-10 101954.png

 

And you can also check the value of your 'status' by use action of 'compose'.

 

Best Regards,

Community Support Team _ Lin Tu

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Highlighted
Helper I
Helper I

Re: Flow not getting data as expected

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

Upcoming Events

Experience what’s next for Power Automate

See the latest Power Automate innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors
Users online (6,903)