cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AlexanderUK
Advocate I
Advocate I

Flow not retaining non exchange email address set as requirement for trigger

Hi all.

 

I'm trying to set up a flow for when a certain email address not within the exchange group (A member of the public for example) emails me, to export the email to a SharePoint document Library.

 

However when using any variant of the "When an email arrives" trigger, when entering this person's email address in the "To:" field. It'll not give any error messages, but when I save the flow and exit out of it and go back in, the email address has disappeared and the field is empty. It will only accept anything within the Exchange Group.

 

Is there a way around this?

49 REPLIES 49
DWC_NZ
Regular Visitor

To create a Trigger Condition for this specific situation click the three dots at the top right of the 'When a new email arrives' action and select Settings. In the bottom of the box click the plus sign to add a new trigger condition and paste in:
@equals(triggerOutputs()?['body/from'], 'test@email.com')

Replacing the test email with your address. To cover multiple emails I think you'll need to have a trigger condition for each address.

malte51234123
Frequent Visitor

Workaround: In the mobile app you can enter an email without this issue.

Thanks for the reply Resident Rockstar.  I have tried adding the trigger condition you gave above but it still isnt converting or saving the email address....

 

Hi Malte

 

It does indeed work in the mobile app, thanks for the suggestion.  But what a pain not being able to use the desktop app for such a simple flow

 

Thanks

 

RR

m-fisher
Frequent Visitor

Hi Powerusers!

 

Any updates on this issue? "Use the mobile app" may not be the definitive answer. The suggestions and the mobile app don't work.

 

regards

VictorIvanidze
Community Champion
Community Champion

Did you try to follow @DWC_NZ 's suggestion?

--------------------------------------------------------------------------------------
Contact me if you are interested in custom Power Automate development.

Hi Victor,

yes that worked, but we should only see it as a workaround, i hope there will be a final solution.

regards

DanEriksen
Frequent Visitor

I totally agree. Removing the ability to add external emails just doesn't make sense! At least not in the from fields. And since the functionality remains in the Android app, I assume someone has just altered the input field incorrectly in the web and desktop apps. Let's hope it gets fixed soon. I am creating new flows in the web app and just adding email conditions in the Android app for now. That works - until @microsoft  fixes this issue.

malte51234123
Frequent Visitor

Still nothing??

VictorIvanidze
Community Champion
Community Champion

Why nothing? You can use @DWC_NZ 's workaround.

--------------------------------------------------------------------------------------
Contact me if you are interested in custom Power Automate development.
CalebGreenberg
Regular Visitor

@VictorIvanidze the solution provided by @DWC_NZ did not work for me. I am trying to add a email address in the from field, but it has not worked for me. 
Also the mobile app is giving me errors to when trying to edit it. When I click on the action it gives me the following error: Operation CreateGraphOnNewEmailPokeSubscription was not found in swagger. 

Any help would be appreciated. 

malte51234123
Frequent Visitor

Workaround via mobile app is not working anymore for me either. absolut crazy. I use the condition workaround, which works

CalebGreenberg
Regular Visitor

Do you know why it would not be working for me? I copied and pasted the exact code and just changed the email but it does work for me. 

malte51234123
Frequent Visitor

Share a screenshot please

CalebGreenberg
Regular Visitor

flow.PNG

malte51234123
Frequent Visitor

Ah okay,

I am using this solution, which is def. working: You can add as much conditions (e.g. email adresses) and/ or as you want

malte51234123_0-1641239838643.png

 

CalebGreenberg
Regular Visitor

I will try it and let you know. 

CalebGreenberg
Regular Visitor

It still does not work for me. 

if you have different email-adresses, you have to use OR in the trigger condition, like

 

@OR(equals(triggerOutputs()?['body/from'], 'email_1@mail.com'),equals(triggerOutputs()?['body/from'], 'email_2@email.com'),equals(triggerOutputs()?['body/from'], 'email_3@email.com')) etc.

 

as the one and only trigger condition, it works!

otherwise the triggers count as "AND"

DanEriksen
Frequent Visitor

But this has to be a bug, right? Can we somehow have this subject untagged as solved, because all we have are workarounds. Not being able to specify a from address outside your own domain in the web and desktop apps cannot be intentional!

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Users online (3,988)