cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
bstroescu
Frequent Visitor

Flow save failed with code 'WorkflowRunActionInputsMissingProperty' for Send Email

Hello all,

 

I ran into an issue as I was finishing adding the last action needed for my flow.  I want to add the Outlook action "Send Email (V2)" and get the following error when trying to save:

Flow save failed with code 'WorkflowRunActionInputsMissingProperty' and message 'The 'inputs' of workflow run action 'Send_an_email_(V2)' of type 'Join' is not valid. Property 'from' is missing.'.


I populated all the required fields as you can see below (no dynamic content, just text):
bstroescu_0-1627424874954.png

 

However, when I peek the code, the inputs are blank:

bstroescu_1-1627424930661.png


When I delete this action, the flow saves without any issues and runs well. However, when I add the Send Email action (V2) or even the send an email notification (V3), the above error shows up and there are no inputs.

 

I never ran into this issue before and need to use the Send Email action. My trigger is a "When an item is created or modified" and has a trigger condition in the Settings. Not sure if this is relevant, but it's the first time I implement this and the first time I run into this error as well.

 

Any tips would be welcome. Thank you!

 

 



 
1 ACCEPTED SOLUTION

Accepted Solutions
bstroescu
Frequent Visitor

Hi Andrew,

I found a solution and tested it, seems to be working.

What I did was delete that Send Email action, save the flow. 

 

Then I went to the trigger and deleted the trigger condition and saved the flow.

 

I added the Send Email action again, and this time inputs were showing normally when peeking code, then saved the flow.

 

When my email action was configured correctly, I added back the trigger condition and saved again.

 

I tested the flows and runs without issues. I will need to move the flow to another environment and test again, but so far seems that the problem is solved.

 

I'd say try the same for the Get Group Members action and see if it works.

View solution in original post

3 REPLIES 3
AndrewGaskins1
Frequent Visitor

I started seeing something similar yesterday with the Azure Get Group Members connector. It has never done this to me before. Did you find a resolution or root cause?

 

The 'inputs' of workflow run action 'Get_group_members' of type 'Join' is not valid. Property 'from' is missing
 
bstroescu
Frequent Visitor

Hi Andrew,

I found a solution and tested it, seems to be working.

What I did was delete that Send Email action, save the flow. 

 

Then I went to the trigger and deleted the trigger condition and saved the flow.

 

I added the Send Email action again, and this time inputs were showing normally when peeking code, then saved the flow.

 

When my email action was configured correctly, I added back the trigger condition and saved again.

 

I tested the flows and runs without issues. I will need to move the flow to another environment and test again, but so far seems that the problem is solved.

 

I'd say try the same for the Get Group Members action and see if it works.

View solution in original post

AndrewGaskins1
Frequent Visitor

Thanks for that bstroescu,

 

Oddly enough the next day the connectors started to work again. I think there was something happening with some of the services when I encountered that. I will keep this in my back pocket for future reference however.

 

Cheers!
Andrew

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

V3_PVA CAmpaign Carousel.png

Community Challenge - Giveaways!

Participate in the Power Virtual Agents Community Challenge

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Top Solution Authors
Users online (1,178)