cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
oaghaei
Helper III
Helper III

Flow sending extra emails outside of the set conditions

I have a flow that sends users an email once they submit a request. I identified two conditions based on which this email should go out. However, the flow sends the email any time I edit the item in the SharePoint list and NOT only when the conditions are met.  Here is my flow:

1. When an item is created or modified (in Sharepoint) ->

2. Get item (Sharepoint) ->

Here I show the item ID and info about the site and list

3. Compose ->

This is the first compose in which I select "Status value" which is the value I need for my first condition
4. Compose 2 ->
This is my second compose in which I select "Project Lead" which is the second item I need for my second condition
5. Condition ->
Output (from the first compose)  is EQUAL to "Not Started" (status value)
Output 2 (from the second compose) is NOT EQUAL to NULL
6. Switch ->
If yes send an email; if no terminate What could be missing?
The flow sends emails even when the status is other than Not Started. Thank you in advance!!

7 REPLIES 7
Pstork1
Dual Super User III
Dual Super User III

Can you post a screenshot of a run? Hard to figure out what's wrong from just your description.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

@Pstork1 I wanted to, but initially, when I typed my first post, it wasn't letting me insert pictures! I was so surprised. Looks like the picture inserting is working now. Here is the overall flow:
 overall flow.JPG

 

Here is the breakdown:
step 1.JPG

 

switch options:

step 3.JPG

 

Please let me know if any other details are needed. 

alrez
Community Support
Community Support

Hi,

 

Can you also include screenshots of a run that still sent the email? Specifically showing what the compose items values are? We should be able to compare those values to the condition and figure out why its sending emails when its not suppose to.

 

Regards,

 

Alex

 

-------

 

Community Support Team _ Alex Rezac
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Pstork1
Dual Super User III
Dual Super User III

I think I know what the problem is.  When doing a get item the connector doesn't include any fields or properties that are null.  So I suspect your condition that checks for null is always failing.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

@Pstork1 Are you suggesting that I change something in the "Get item"? Not sure if I am following you. I thought when it's getting an item, it's getting whatever the contents of the item are. Do you by any chance have a solution to fixing this? 🙂

get item.JPG

@alrez thank you for making me look into it. I realized where the issue was (another flow with other conditions).

I found the problem. It turned out not to be this specific flow. I think I also have a solution in mind for it. Thank you again for taking the time to look at this issue! @Pstork1 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (1,421)