cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flow showing as failed but is actually working

Hi all,

 

Background:

 

I have two libraries for the HR site:

1) Current Employees

2) Leavers

 

Both libraries are set up the same and work with document sets - one of the columns in both libraries is Employee status with the options of current employee and leaver.

 

All employee files are held in the current employees library, when an employees status gets changed to leaver, the flow is designed to move that employees document set and documents within into the leavers library.

 

So when the flow is in action, it will show the run as failed, when in reality the leavers document set and documents have actually moved from the employees library to leavers library which to me means it has worked/ succeeded.

 

The only time it will show as succeeded is when no document sets and documents have moved from the employees library to the leavers library. The reason for this is because no-one has been marked as a leaver within the current employees library.

 

So whilst the flow does work, the logs are showing as failed - is this a bug? or does my flow need adjustments?

 

Many thanks,

 

Sarah 

 

6 REPLIES 6
fchopo
Super User
Super User

Hi @Anonymous 

Which is the error message you receive? Your flow need any kind of adjustment, since there's an error.

Regards,

Ferran

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!
Anonymous
Not applicable

Hi Ferran,

 

The message is that it's failed. I've attached a screenshot.

the two failures were the times when it actually worked.

the succeeded ones are when there haven't been any leavers to moveUntitled.png 

fchopo
Super User
Super User

And for the failed ones, which error are you receiving?

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!
Anonymous
Not applicable

Hi Ferran,

 

The error message I am getting is An action failed. No dependent actions succeeded.

fchopo
Super User
Super User

You should have receieved a more detailed message. If not, it's really difficult to help you with such information.

Regards,

Ferran

Did I answer your question? Please consider to mark my post as a solution to help others.
Proud to be a Flownaut!
jdoss
Resolver III
Resolver III

The flow failed just means that every step did not complete. So, the functionality may have worked but something that took place after may have failed. If you click on the timestamp of one of the failed flows in your image it will open up the flow run and you will be able to see where it actually failed and a more detailed error message. 

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Users online (2,105)