cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flow suddenly fails to return records from SQL

I have a flow that I created and ran successfully - I have not made a change but suddenly it stopped working!!!  I didn't change anything but not it is saying it isn't finding records.

runhist.png

The filter is

Year(REQST_APPRVL_REQ_DT) eq 2019 and Month(REQST_APPRVL_REQ_DT) eq 06 and Day(REQST_APPRVL_REQ_DT) eq 13

 

If I run the sql query I get rows for this date so there is data:

select REQST_AGRMNT_AVP_EML
from AVP_Claims
where REQST_APPRVL_REQ_DT = '2019-06-13'

 

RESULTS

REQST_AGRMNT_AVP_EML
dawn.xxxxxxx@xxxxx.com
dawn.xxxxxxx@xxxxx.com
dawn.xxxxxxx@xxxxx.com
dawn.xxxxxxx@xxxxx.com
dawn.xxxxxxx@xxxxx.com

 

errormsg.png

I don't get why this is happening 😞  Anyone know what I can do?

2 ACCEPTED SOLUTIONS

Accepted Solutions
Dual Super User
Dual Super User

Re: Flow suddenly fails to return records from SQL

Hey @Anonymous Glad that it worked! Please note that in some connectors, there might be caching issues and such issues are the ones that do not leave a trace and it is difficult to track what caused the problem and so, I approached the hit and trial method from the basics just to check that we are not making any fundamental mistake. Also, in such scenarios, instead of deleting/ re creating the entire flow, you might want to delete the current connection to SQL and create a new one. Alternatively, you can log out of the current session, close the window and start a fresh session. (Just an FYI for any future issues on similar lines)

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Anonymous
Not applicable

Re: Flow suddenly fails to return records from SQL

Yes it appears to be some caching issue and eventually it clears itself.  Thanks for your responses.

View solution in original post

7 REPLIES 7
Dual Super User
Dual Super User

Re: Flow suddenly fails to return records from SQL

Hi @Anonymous 

 

Can you confirm that there has been no change on the SQL Server Database? Can you confirm that this "(REQST_APPRVL_REQ_DT)" column exists on the SQL Database?

Community Support Team
Community Support Team

Re: Flow suddenly fails to return records from SQL

Hi @Anonymous ,

 

I have just made a test with SQL Server Get rows. The function used in Filter query returns value successfully.

 

Please make sure SQL Server is running properly on your side.

 

Please check the table and make sure there is no change made on the table.

1.PNG2.PNG 

 

Best regards,

Mabel

 

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Re: Flow suddenly fails to return records from SQL

there have been no table changes nor changes to the server. I manage both so there isn't a possibility that something changed without my nowing.

 

If I run the sql query I get rows for this date so there is data:

select REQST_AGRMNT_AVP_EML
from AVP_Claims
where REQST_APPRVL_REQ_DT = '2019-06-13'

 

RESULTS

REQST_AGRMNT_AVP_EML
dawn.xxxxxxx@xxxxx.com
dawn.xxxxxxx@xxxxx.com
dawn.xxxxxxx@xxxxx.com
dawn.xxxxxxx@xxxxx.com
dawn.xxxxxxx@xxxxx.com

Dual Super User
Dual Super User

Re: Flow suddenly fails to return records from SQL

@Anonymous 

 

Can you check and confirm what is the datatype of the "REQST_APPRVL_REQ_DT" column? 

Anonymous
Not applicable

Re: Flow suddenly fails to return records from SQL

I gave up and deleted and recreated the flow - now it connects fine again.  The field type hadn't changed it was always date.  Thanks for responding.

Dual Super User
Dual Super User

Re: Flow suddenly fails to return records from SQL

Hey @Anonymous Glad that it worked! Please note that in some connectors, there might be caching issues and such issues are the ones that do not leave a trace and it is difficult to track what caused the problem and so, I approached the hit and trial method from the basics just to check that we are not making any fundamental mistake. Also, in such scenarios, instead of deleting/ re creating the entire flow, you might want to delete the current connection to SQL and create a new one. Alternatively, you can log out of the current session, close the window and start a fresh session. (Just an FYI for any future issues on similar lines)

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Anonymous
Not applicable

Re: Flow suddenly fails to return records from SQL

Yes it appears to be some caching issue and eventually it clears itself.  Thanks for your responses.

View solution in original post

Helpful resources

Announcements
firstImage

New Ranks and Rank Icons in April

Read the announcement for more information!

firstImage

Better Together Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Community Summit North America

The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (9,527)