cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jimmart
Helper I
Helper I

Flow that adds a record to another entity

Hi Guys,

 

Im trying to create a flow that adds or could even update a record from another entity.

 

To start it off I have an entity named Integrations that has a N-N relationship with Products, on the products there is a lookup field that references an Integration.

 

Image below is on a product form.

jimmart_0-1598753568822.png

 

Now what I am trying to do is that when that product is added on the Order line I want it so that it updates the respective Integration record with the Account that purchased the product.

 

Image is what the Integrations form look like, there is a reference to the Product here via a lookup field.

 

jimmart_2-1598753726978.png

 

 

As you can see below there is a + button where you can add the account that you wanted which is what i want to automate.

 

I created a flow that basically triggers once a product is added on the Order Line, it gets the record for the account, the product, the order and the integration. However it fails on the Get a record - Integrations part

 

This is the integration part, I am trying to find the specific integration by using the IntegrationsID field (lookup field) thats on the products forms) however it fails.

jimmart_3-1598754002814.png

 

Here is the error.

 

jimmart_4-1598754120303.png

 

I think the error here is due to the lookup field giving out the string and not the guid\itemid for the specific Integration, do you guys have any idea how i could get that? or is my logic all totally wrong? Can anyone please point me out how to get this done? Thanks a lot.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Mira_Ghaly
Dual Super User II
Dual Super User II

@jimmart 

try to add es to new_affiliateses

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

View solution in original post

10 REPLIES 10
Mira_Ghaly
Dual Super User II
Dual Super User II

@jimmart 

Can you please paste full screenshots of your flow?

Also from your screenshot i see that Integration ID is Optional , so are you sure the record contains value for integration id?

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Hi Mira,

 

Thanks for the reply. ive gotten over that error now im getting a nerror with adding the record already.

 

It comes up with this error.

 

jimmart_0-1598806605001.png

 

This is the configuration for that flow.

 

jimmart_1-1598806642347.png

 

 

Im using the integration ID to point out what is saved but seems to be failing.

 

Do you know why that is so? Ive tried just the integrationID itself and still has the same error.

Mira_Ghaly
Dual Super User II
Dual Super User II

@jimmart 

The issue is that you are using the Integrations name not its schema name which i guess it can be new_integrations or whatever prefix you are using.

 

If this post helps you with your problem, please mark your as Accepted solution.

If you like my response, please give it a Thumbs Up.

MG (Naturally Curious)

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
v-alzhan-msft
Community Support
Community Support

Hi @jimmart ,

 

Would you please take a try to leave the integration field blank, run the flow to see what is the integration for the special record?

 

Best Regards,

Alice

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @Mira_Ghaly ,

 

I have tried using this however it still has the same error.

Error.PNG

 

This is what the entity looks like. 

 

 

This is what the flow looks like

Integrations  Entity.png

Flow.PNG

 

I have tried /integrations/ and /integration/ both come up with the same error as far as i remember, also tried it with just the value.

 

Do you have any other ideas?

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Hi @v-alzhan-msft 

 

I have tried your suggestion and it works, it creates it automatically however there is no reference to the Integration Entity that i created. Do you have any other ideas? Thanks

Mira_Ghaly
Dual Super User II
Dual Super User II

@jimmart 

can you share a screen of your integration entity schema name?It needs the plural name like if it is /accounts

 

If this post helps you with your problem, please mark your as Accepted solution.

If you like my response, please give it a Thumbs Up.

MG (Naturally Curious)

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Hi @Mira_Ghaly 

 

Is this what you were referring to?

 

jimmart_0-1598918564607.png

 

 

 

Mira_Ghaly
Dual Super User II
Dual Super User II

@jimmart 

try to add es to new_affiliateses

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

View solution in original post

@Mira_Ghaly 

 

Thanks, ur recommendation fixed it, as always you have fixed the problem. 😄 Solution Sage! 😄

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (10,227)