cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ajoconnell
Regular Visitor

Flow to Email Individual Documents from a Document Set

 

 

 

 

Hi!

 

I'm fairly new to Power Automate and I'm looking to create a flow that will take the each document in a document set and send individual emails with the document attached.

 

The Document Set:

Capture.PNG

The "Example" set:

Capture2.PNG

 

I've tried "Get file content" but I keep getting an error.  Are there any better ways to accomplish this?

 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

After some troubleshooting, I was able to finally achieve what I was looking to do.  

 

Using a Document Set, I needed to upload multiple documents and have an email sent with each file attached to one document set manually:

 

Doc Library.png

In the "Example" doc set, there are three files:

 

Files.png

Flow trigger "Document Transmission":

Flow.png

 

Once triggered, it sends off three different emails :

Final.png

 

 

View solution in original post

9 REPLIES 9
efialttes
Super User III
Super User III

@ajoconnell 

Is the 'Get File content' action block the one that throws an error? If so, which 'File identifier' are you using as its input?

Any screenshot from your Flow design and/or execution error is appreciated

Thanx!



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Hi @efialttes ,

 

The trigger I used was a manual "For a selected file"

 

1.png

 

For "Get File Properties" I used the ID from "For a selected file" and for "Get File Content" I used the "Get File Properties" identifier.

 

Hi again

Thanx for the screenshot!

I've just implemented these three steps and the execution succeeds.

Flow_DocumentSet.png

 

Can you specify a bit more what do you mean when mentioned that 'I've tried "Get file content" but I keep getting an error'?

Thanx!

 

BTW here you are a couple of links to resources on Document Sets and Microsoft Flow

https://sergeluca.wordpress.com/2019/04/17/microsoft-flow-and-document-sets-while-waiting-for-modern...

https://karinebosch.wordpress.com/2018/11/08/microsoft-flow-create-a-document-set/

Hope this helps

 



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



The error I get is:

 

{
"status": 404,
"message": "File not found\r\nclientRequestId: 0fcf9aaa-fdf6-4ad2-9440-644b7319a81d\r\nserviceRequestId: 0fcf9aaa-fdf6-4ad2-9440-644b7319a81d"
}
 
tempsnip.png
 
 

@ajoconnell 

I think you should doublecheck the value currently assigned as 'Get file content' File Identifier.

On the execution screenshot your shared, I see your file identifier does not include the file extension.

Now, when I successfully execute my test flow, I can see the file extension:

Flow_ForSElectedItem_5.png

Please hover your mouse over the dynamic content you currently has assigned as 'File identifier' input and verify it matches with the one I assigned

body('Get_file_properties')?['{Identifier'}]

 

Hope this helps



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Capture.PNG

Weird 🤔

Is it 'Site address' the same in both action blocks?

Did you try to remove and add the 'Get file content' action block again?

And, doublecheck if the connection your are currently using for these two action blocks is the same?

And, make sure you are executing the flow, I mean not using 'Test' option 'Using data from previous runs' from Designer view?

Thanx!

 



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



After some troubleshooting, I was able to finally achieve what I was looking to do.  

 

Using a Document Set, I needed to upload multiple documents and have an email sent with each file attached to one document set manually:

 

Doc Library.png

In the "Example" doc set, there are three files:

 

Files.png

Flow trigger "Document Transmission":

Flow.png

 

Once triggered, it sends off three different emails :

Final.png

 

 

View solution in original post

OMG!

That's the reason why there was not an extension on your 'Get file properties' File Identifier output!

 

Congrats! Please note I've just marked your last reply as 'Solution'. I think it will be very helful for others facing this same issue.

Thanks for spending some time to share the way you fix it!

 

 



Each time you click on any of our inspiring answers 'Thumb up' icon...
...an ewok scapes from the stormtroopers.

Be grateful, Thumbs up! Save the Galaxy for free!


Escribo sobre Power Automate en:
https://medium.com/anyone-can-automate/

Proud to be a Flownaut!



Helpful resources

Announcements
MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Top Kudoed Authors
Users online (17,625)