cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RadVine
Frequent Visitor

Flow with expression and dynamic content from Sharepoint List

I feel so stupid because I am failing to find information on how to combine an expression function like addDays(utcNow(), NumberDaysfromSharepointListColumn) and use the result as Text in a Message or if-Conditions. The triggerbody concept is hard to understand for me as a beginner.

 

I tried to write it as text, as expression and switching the tab to dynamic content and googled it and found one solution but, can it really be this complex?

Use Compose to get the Sharepoint Value, use then the expression with outputs("Composename").

Is it really that hard to accomplish what I need? It will get tedious with more complex with more inputs.

3 REPLIES 3
sudharsan1985
Solution Sage
Solution Sage

Hi @RadVine 

Tell us what would like to achieve, we will help you with the flow actions and conditions.

Hope it helps, please like it or mark it as a solution if it resolves your clarification or issue
-Sudharsan K...
ScottShearer
Super User
Super User

@RadVine 

As @sudharsan1985 mentioned, let us know exactly what you are trying to do and we will try to assist.

You can find documentation on expressions here.

I don't think that anyone would disagree with you when you say that the environment for building expressions could be better...  In fact, the Power Automate team is working on enhancements to simply the expression creation experience.  If you turn on experimental features in your environment, you can take a look at what they're working on.  I would not suggest using the experimental features for you Production Flows.

Exp1.jpg

Exp2.jpg

 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

Exact problem is that once the expression was updated I could not edit it anymore. Basically I had to write the expression again from scratch everytime there I noticed there was a problem. 

 

Noticed that some other features in a "for each"-Loop didn't work either. Switched from Chrome Edge to Chrome and it worked.

When I was opening the debugging console outputs showed there were problems with login and other warnings that did not show up in Chrome. Working now.

 

Thanks for the tip with experimental settings, guys.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Super User 2 - 2022 Congratulations 768x460.png

Welcome Super Users

The Super User program for 2022- Season 2 has kicked off!

Users online (3,958)