cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
dm_elementwa
Level: Powered On

Flow works for one site but not another

I have a test sharepoint site I use for building and testing flows with forms and sharepoint lists before applying them to my company's live sharepoint site. 

I finally figure out a flow that will take a form submission and update/overwrite an item in a sharepoint list.

 

When I build and run the exact same flow using my live site forms and lists, it updates my entry but duplicates it as well.

 

Any ideas why it would be doing this?

Test Flow and Live Flow attached. (Note the 'update item' has an extra field in the test flow but not in the live site flow. Not sure if this is a hint as to what might be going on?).

Screen Shot 2019-10-21 at 3.39.46 pm.pngTest Site - Part 1Screen Shot 2019-10-21 at 3.40.36 pm.pngTest Site - Part 2Screen Shot 2019-10-21 at 3.40.46 pm.pngTest Site - Part 3Screen Shot 2019-10-21 at 3.47.03 pm.pngLive Site - Part 1Screen Shot 2019-10-21 at 3.47.14 pm.pngLive Site - Part 2Screen Shot 2019-10-21 at 3.47.21 pm.pngLive Site - Part 3

1 ACCEPTED SOLUTION

Accepted Solutions
Dual Super User
Dual Super User

Re: Flow works for one site but not another

Hey @dm_elementwa 

 

Can you check and confirm that both the lists have the same schema (Same columns)? If they are same, can you save the flow and do a refresh page for the live one to check if you see the otehr column now? 

 

Also, can you check and confirm if there is any other flow that is triggered when the form is submitted and creates a new item in the list? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

2 REPLIES 2
Dual Super User
Dual Super User

Re: Flow works for one site but not another

Hey @dm_elementwa 

 

Can you check and confirm that both the lists have the same schema (Same columns)? If they are same, can you save the flow and do a refresh page for the live one to check if you see the otehr column now? 

 

Also, can you check and confirm if there is any other flow that is triggered when the form is submitted and creates a new item in the list? 

 

Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Gristy
Level 10

Re: Flow works for one site but not another

the update item action will not create a duplicate item.

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 381 members 6,654 guests
Please welcome our newest community members: