cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Flows Approval Actionable E-mail not working

As of Friday, our approval flows now re-direct to the web browser (webpage) for approval, rather than being actionable in the e-mail (both in desktop client and OWA). We have changed nothing. Even the Markdown formatting in our approval e-mail broke (again, last modified date on the Flow is months ago). I checked our ExchangeOnline config:

 

Get-OrganizationConfig | ft ConnectorsActionableMessagesEnabled,SmtpActionableMessagesEnabled

And both are set to True. I'm not sure what went wrong. New approval e-mails I test creating are doing the same thing.  I tried setting them to $false then back to $true, same issue.

 

I used the Actionable Messages Debugger tool which shows the below error:

Adaptive card signature validation failed - Failed to validate signature

 

But I'm not designing my own card/adaptive card, I'm using the basic out-of-the-box Approve/Reject Flow.

 
14 REPLIES 14
StevenRichards
Helper II
Helper II

Same here. Started on the 30th. Surprised more people aren't commenting on this.

Anonymous
Not applicable

just to add, users have also noticed that all previous Approval emails now show the option to Approve/Reject, instead of stating that they have already been dealt with

wmwoodall
Frequent Visitor

Same issue for me so hoping to bump

StevenRichards
Helper II
Helper II

I created a ticket. Unlikely to get a resolution any time soon. They transferred the ticket to the outlook team.

aleprieur
Regular Visitor

Please keep us posted. Super frustrating!

Anonymous
Not applicable

I also have a ticket open with through Power Platform support a week ago, but am expecting pretty much the same a slow investigation.

aleprieur
Regular Visitor

They (Microsoft) know they messed it up, it'd just be nice if they told us. They've conveniently added this to the messages, which leads to useless information with no solution.

aleprieur_1-1649859100907.png

 

aleprieur
Regular Visitor

Mine magically started working again this morning. You?

Anonymous
Not applicable

Unfortunately not, not through the desktop client or through OWA Online.

Mine worked briefly yesterday afternoon. Back to not working now unfortunately

StevenRichards
Helper II
Helper II

Ours are working again as of last night.

Anonymous
Not applicable

Yep, same new Approvals seem to be working.  No advisory from MS though as to what happened.

Anonymous
Not applicable

The support person I was talking to said there was an "issue" with the Approvals connector, and that they had deployed a fix which resolved the issue.

Sounds fishy... translation: "We screwed up"

Helpful resources

Announcements
October Events

Mark Your Calendars

So many events happening this month - don't miss out!

 WHAT’S NEXT AT MICROSOFT IGNITE 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Register for a Free Workshop.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Users online (3,233)