cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Lucas718
Frequent Visitor

Formatting email link to Sharepoint item

I have a Flow created that will send an email when a Sharepoint item is modified.  It works fine except I don't like the way the Link To Item looks in the email.

 

I'd like to format it just to say Click Here instead of displaying the full link like this: 

https://oursitename.sharepoint.com/sites/IT/_layouts/15/listform.aspx?andabunchmorestuffblahblahblah

 

Is there any way to do that?  It would make the email a bit easier to look at.

 

1 ACCEPTED SOLUTION

Accepted Solutions

Have you tried the HTML option in the advanced options and then use 

<a href=...>click here</a>

View solution in original post

16 REPLIES 16

Have you tried the HTML option in the advanced options and then use 

<a href=...>click here</a>

View solution in original post

Of course, the simplest option is the best.  I didn't even think of that,  Thanks!

I'm having the same issue, but I have tried using the IsHtml = Yes, and formatting as <a href="Link to form">click here</a> but it is ignored. The rest of the html in the email works well (basic paragraphs, lists), its just the formatting of the link...

Anyone got any ideas?

@SuzanneHunt, Are you  using double or single quotes around the url?

double...should they be single?

yes

just tried:

screen2.jpgscreen3.jpg

 

and the email I got was:

screen1.jpg

Ah you are initialising a variable. I thought you were adding that link to an HTML formatted email.

 

Can you try adding that bit of html directly into the email body rather than using the variable. 

just added this to the email action:

screen4.jpg

 

and got:

screen5.jpg

 

even tried deleting the email action and re-adding it

 

I think that the clue is in the visible < and > in your HTML output. It looks like the HTMLmode isn't recognised somehow.

its just for the link...I have <ul> tags working, <p> tags but the <a href>...thats the headache. I'll look at it again with clear eyes tomorrow, its 1.30am so time to put this away for now....thanks for your help Pieter!

Been getting emails notifying me that this thread has been updated. 

 

Try adding the Dynamic Content item "Link to Item" instead of typing out the url.   That worked for me.

 

Edit - actually now that I look at your issue a little closer, I'm not sure my solution is going to work for you.

 

 

Ok, I've come back to this, interesting observation: if the email is sent to an internal email address it works, if the email address is external to my tenant then it doesnt work. Can you try that to see if the same thing happens?

Thanks Lucas, yeah I'm trying to send a link to an external email that contains a link to a form available externally via MS Forms rather than the list item, sorry for hijacking your thread!

No that doesn't work in a flow. No amount of formatting does. Everything keeps returning the full url.

Pieter was on to the solution.  You have to switch over to HTML view in the flow to insert the line.  Took me a little while to figure it out today.

Helpful resources

Announcements
MPA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Users online (1,038)