cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Forms doesn't trigger flow.

Hi!

I wanted to build a simple flow that will inform me about new response in Forms.

It's extreamly simple:

New response=>notify.flow.JPG

 

 

I have tested mobile notification with flow button and they seemed ok.

Form do accept responses correctly.

 

History of triggered flows seys - nothing...

 

What is wrong?

How to debug this?

20 REPLIES 20
v-micsh-msft
Community Support
Community Support

Hi @Anonymous,

 

Thanks for the feedback.

Symptom could be reproduced from my side.

And feedback has been sent on our channel.

I will post back if I got any response.

Appreciate your understanding.

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
BluWrld
New Member

I'm having a similar issue when trying to trigger an email send from Forms (using the Flow template).

 

Flow is checking every 5 mins but is skipping (code 202) as it doesn't find any results dispite having submitted a dozen reponses myself.

 

Under Run History > Learn More the Run History Summary Status shows as "Trigger failed".

Hi All,

 

I got a response tolding that there is a problem with the Form trigger.

Once a skipped happens, the trigger would send a re-try after some delay. and during the delay there would be no trigger fires, which means the trigger will not work during the delay.

The Team is working on this, but currently there is no ETA.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I Also get a error 202.

 

Statuscode
202
Headers
{ "Pragma": "no-cache", "X-CorrelationId": "a5252472-9074-41cb-97e5-aaaf97c9f4fa,b113dc11-8934-4710-a4ce-5551022b8404", "X-UserSessionId": "a5252472-9074-41cb-97e5-aaaf97c9f4fa,2beca4e7-4a5f-4992-b91d-74074db3fad6", "X-OfficeFE": "FormsSingleBox_IN_9,FormsSingleBox_IN_9", "X-OfficeVersion": "16.0.8516.6676,16.0.8516.6676", "X-OfficeCluster": "neu-000.forms.office.com,neu-000.forms.office.com", "retry-after": "3600", "OData-Version": "4.0", "X-Content-Type-Options": "nosniff", "Timing-Allow-Origin": "*", "Cache-Control": "no-cache", "Date": "Mon, 21 Aug 2017 14:54:44 GMT", "Location": "https://europe-001.azure-apim.net/apim/microsoftforms/shared-microsoftform-ccb26a61-38f6-43d1-95e8-f...", "P3P": "CP=\"CAO DSP COR ADMa DEV CONi TELi CUR PSA PSD TAI IVDi OUR SAMi BUS DEM NAV STA UNI COM INT PHY ONL FIN PUR\",CP=\"CAO DSP COR ADMa DEV CONi TELi CUR PSA PSD TAI IVDi OUR SAMi BUS DEM NAV STA UNI COM INT PHY ONL FIN PUR\"", "X-AspNet-Version": "4.0.30319", "X-Powered-By": "ASP.NET", "Content-Length": "0", "Expires": "-1" }
 
I noticed that at the Trigger I keep seeing "(example)"
 
Does anyone have a solution?

I had Flow pick up a form response once ... but now I always have the same issue.

 

Status code
202
Headers
{ "Pragma": "no-cache", "X-CorrelationId": "c9047ff9-dca3-4acc-a165-626812c25c9b,e4cb17b7-6e28-4bc9-aad0-b74c35ece43d", "X-UserSessionId": "c9047ff9-dca3-4acc-a165-626812c25c9b,ab8401cb-deb4-4ed2-8c99-ea673eea22ca", "X-OfficeFE": "FormsSingleBox_IN_12,FormsSingleBox_IN_12", "X-OfficeVersion": "16.0.8516.6676,16.0.8516.6676", "X-OfficeCluster": "ea-000.forms.office.com,ea-000.forms.office.com", "retry-after": "3600", "OData-Version": "4.0", "X-Content-Type-Options": "nosniff", "Timing-Allow-Origin": "*", "Cache-Control": "no-cache", "Date": "Tue, 22 Aug 2017 02:32:59 GMT", "Location": "https://australia-001.azure-apim.net/apim/microsoftforms/shared-microsoftform-e319e732-9d78-4ec3-9ef...", "P3P": "CP=\"CAO DSP COR ADMa DEV CONi TELi CUR PSA PSD TAI IVDi OUR SAMi BUS DEM NAV STA UNI COM INT PHY ONL FIN PUR\",CP=\"CAO DSP COR ADMa DEV CONi TELi CUR PSA PSD TAI IVDi OUR SAMi BUS DEM NAV STA UNI COM INT PHY ONL FIN PUR\"", "X-AspNet-Version": "4.0.30319", "X-Powered-By": "ASP.NET", "Content-Length": "0", "Expires": "-1" }
Tonyo932
Frequent Visitor

Hi

 

Has this been resolved yet as I have had the same issue.

Status code

202

{
  "Pragma": "no-cache",
  "X-CorrelationId": "2e99056a-8f1f-4bd4-aeed-d0a00ab2a5c2,b80d0e41-95ac-44f6-87f3-c7ed33180861",
  "X-UserSessionId": "2e99056a-8f1f-4bd4-aeed-d0a00ab2a5c2,785b361a-d5b1-481e-b107-78be4bbc0d25",
  "X-OfficeFE": "FormsSingleBox_IN_3,FormsSingleBox_IN_3",
  "X-OfficeVersion": "16.0.8517.6678,16.0.8517.6678",
  "X-OfficeCluster": "neu-000.forms.office.com,neu-000.forms.office.com",
  "retry-after": "3600",
  "OData-Version": "4.0",
  "X-Content-Type-Options": "nosniff",
  "Timing-Allow-Origin": "*",
  "Cache-Control": "no-cache",
  "Date": "Tue, 22 Aug 2017 12:09:08 GMT",
  "Location": "https://europe-001.azure-apim.net/apim/microsoftforms/shared-microsoftform-80fbaf8b-703f-46ac-a56e-d59e634d0559/trigger/formapi/api/forms('a069rEXod0aFPKjST682VZf1F1QsGw5LviHAdjV6UvpUOEpPWDNKWEZUVk1IWFBRVUE5MFlJNklQTi4u')/responses?triggerState=2017-08-22T11:39:25.470Z",
  "P3P": "CP=\"CAO DSP COR ADMa DEV CONi TELi CUR PSA PSD TAI IVDi OUR SAMi BUS DEM NAV STA UNI COM INT PHY ONL FIN PUR\",CP=\"CAO DSP COR ADMa DEV CONi TELi CUR PSA PSD TAI IVDi OUR SAMi BUS DEM NAV STA UNI COM INT PHY ONL FIN PUR\"",
  "X-AspNet-Version": "4.0.30319",
  "X-Powered-By": "ASP.NET",
  "Content-Length": "0",
  "Expires": "-1"
}

I was working with an O365 support team member regarding this same issue. When I went to show her that submitting the form doesn't trigger the action, it actually worked this time. This happened today (8/22/17) around 1PM. I have tested multiple times since then with the flow succeeding each time. This same flow wasn't working all last week, and I have had multiple other flows based on a Forms submission trigger that weren't working too. It seems that it may be fixed. Try again and see if it works now. Good luck!

Hi Jared

I had the same problem for a week or so as well then today like you said trigger started working again.

Hopefully it will keep working as I am looking to use this within a team/group and it would be a good way to collect information and send a email with the relavent information.

But if this issue reocurrs too often I will have to rethink about using these flows.

 

Regards

Tony

Anonymous
Not applicable

Doesn't work for me.

 

I am not knowledgeable in coding, so I can't help troubleshoot very well. My recommendation is to try to recreate the flow from scratch to see if that works. If that doesn't work, copy the output from the run details (e.g., Run History>Checks (no new data)>Skipped details>Forms trigger details). That example path is assuming the flow is still not triggering on a new submission in Forms. Maybe someone more knowledgeable will be able to find something in the output of the run details to help resolve the issue.

yoshihirok
Memorable Member
Memorable Member

Hi @Anonymous

 

Yes,

In my test, Forms trigger flow after 0 minutes to 50 minutes.

I continue test 3 days, over 30 times in 2 tenants / 2 forms / 2 flows.

 

and I share a Flow which notify the duration time from submitted forms to run flow.

 

Posts "Slow between submit Forms and run Flow, over 50 minutes"

https://powerusers.microsoft.com/t5/General-Flow-Discussion/Slow-between-submit-Forms-and-run-Flow-over-50-minutes/m-p/51954#M8395

 

Regards,

Yoshihiro Kawabata

 

Anonymous
Not applicable

Im in the same place with a very simple email notification for Form response. Here's the output for my "Skip". Any help would be appreciated.

 

{ "Pragma": "no-cache", "X-CorrelationId": "ec586221-d212-4ea0-a67a-626b7fdf9fc8,e309ec08-3b85-4351-bfb4-401c95a1ae74", "X-UserSessionId": "ec586221-d212-4ea0-a67a-626b7fdf9fc8,e757a6a5-c226-4df7-bd1d-99f2102e4cfb", "X-OfficeFE": "FormsSingleBox_IN_8,FormsSingleBox_IN_8", "X-OfficeVersion": "16.0.8518.6677,16.0.8518.6677", "X-OfficeCluster": "wus-000.forms.office.com,wus-000.forms.office.com", "retry-after": "3600", "OData-Version": "4.0", "X-Content-Type-Options": "nosniff", "Timing-Allow-Origin": "*", "Cache-Control": "no-cache", "Date": "Thu, 24 Aug 2017 10:57:55 GMT", "Location": "https://msmanaged-na.azure-apim.net/apim/microsoftforms/shared-microsoftform-3a817171-4399-4139-b6dc...", "P3P": "CP=\"CAO DSP COR ADMa DEV CONi TELi CUR PSA PSD TAI IVDi OUR SAMi BUS DEM NAV STA UNI COM INT PHY ONL FIN PUR\",CP=\"CAO DSP COR ADMa DEV CONi TELi CUR PSA PSD TAI IVDi OUR SAMi BUS DEM NAV STA UNI COM INT PHY ONL FIN PUR\"", "Server": "Microsoft-IIS/8.5,Microsoft-HTTPAPI/2.0", "X-AspNet-Version": "4.0.30319", "X-Powered-By": "ASP.NET", "Content-Length": "0", "Expires": "-1" }

@Anonymous, under status code, do you see 202? I will compare what you pasted to my Headers output to see if I can find anything meaningful. Unfortunately, I know very little about this stuff, so I probably won't be much help. Hopefully someone else will have some more information to add.

Anonymous
Not applicable

It is! Error 202. So I broke it down and experimented with the Flow, while adding one additional piece of information to the email trigger with each new response, and the Error 202 came in for me when I tried to have the email add the "Responder's Email address" into the cc field. Any thoughts on the Error 202, or why that particular piece of information (Form Submitter's Email Address) would break down the flow?

From what I gathered when speaking to O365 support, the 202 code is actually a status code and not an error code. Mindy from support explained that this was the equivalent to a HTTP status 202. Here is some information on that. Was the Responder's Email Address the first piece of dynamic content added?

Anonymous
Not applicable

HAs this ever been fixed, have a form that needs to trigger a flow and have the form put into sharepoint list and still no worky

Yep, I believe it is. I have not had an issue with flows using Forms as a trigger for at least the past six months, probably longer.

Anonymous
Not applicable

Well thats annoying... How long on average does it taake to trigger?

 

Below is all i need it to do for now, and no matter who fills the form in it just won't trigger

2018-08-21_1603.png

Hmm. It looks like it should work to me, but I am definitely not an expert with flows. Personally, my next step would be to read the error reports and activity log. If nothing seems wrong there, I would recreate the flow from scratch and see if that fixes it.

Helpful resources

Announcements

Check out the Copilot Studio Cookbook today!

We are excited to announce our new Copilot Cookbook Gallery in the Copilot Studio Community. We can't wait for you to share your expertise and your experience!    Join us for an amazing opportunity where you'll be one of the first to contribute to the Copilot Cookbook—your ultimate guide to mastering Microsoft Copilot. Whether you're seeking inspiration or grappling with a challenge while crafting apps, you probably already know that Copilot Cookbook is your reliable assistant, offering a wealth of tips and tricks at your fingertips--and we want you to add your expertise. What can you "cook" up?   Click this link to get started: https://aka.ms/CS_Copilot_Cookbook_Gallery   Don't miss out on this exclusive opportunity to be one of the first in the Community to share your app creation journey with Copilot. We'll be announcing a Cookbook Challenge very soon and want to make sure you one of the first "cooks" in the kitchen.   Don't miss your moment--start submitting in the Copilot Cookbook Gallery today!     Thank you,  Engagement Team

Announcing Power Apps Copilot Cookbook Gallery

We are excited to share that the all-new Copilot Cookbook Gallery for Power Apps is now available in the Power Apps Community, full of tips and tricks on how to best use Microsoft Copilot as you develop and create in Power Apps. The new Copilot Cookbook is your go-to resource when you need inspiration--or when you're stuck--and aren't sure how to best partner with Copilot while creating apps.   Whether you're looking for the best prompts or just want to know about responsible AI use, visit Copilot Cookbook for regular updates you can rely on--while also serving up some of your greatest tips and tricks for the Community. Check Out the new Copilot Cookbook for Power Apps today: Copilot Cookbook - Power Platform Community.  We can't wait to see what you "cook" up!    

Welcome to the Power Automate Community

You are now a part of a fast-growing vibrant group of peers and industry experts who are here to network, share knowledge, and even have a little fun.   Now that you are a member, you can enjoy the following resources:   Welcome to the Community   News & Announcements: The is your place to get all the latest news around community events and announcements. This is where we share with the community what is going on and how to participate.  Be sure to subscribe to this board and not miss an announcement.   Get Help with Power Automate Forums: If you're looking for support with any part of Power Automate, our forums are the place to go. From General Power Automate forums to Using Connectors, Building Flows and Using Flows.  You will find thousands of technical professionals, and Super Users with years of experience who are ready and eager to answer your questions. You now have the ability to post, reply and give "kudos" on the Power Automate community forums. Make sure you conduct a quick search before creating a new post because your question may have already been asked and answered. Galleries: The galleries are full of content and can assist you with information on creating a flow in our Webinars and Video Gallery, and the ability to share the flows you have created in the Power Automate Cookbook.  Stay connected with the Community Connections & How-To Videos from the Microsoft Community Team. Check out the awesome content being shared there today.   Power Automate Community Blog: Over the years, more than 700 Power Automate Community Blog articles have been written and published by our thriving community. Our community members have learned some excellent tips and have keen insights on the future of process automation. In the Power Automate Community Blog, you can read the latest Power Automate-related posts from our community blog authors around the world. Let us know if you'd like to become an author and contribute your own writing — everything Power Automate-related is welcome.   Community Support: Check out and learn more about Using the Community for tips & tricks. Let us know in the Community Feedback  board if you have any questions or comments about your community experience. Again, we are so excited to welcome you to the Microsoft Power Automate community family. Whether you are brand new to the world of process automation or you are a seasoned Power Automate veteran - our goal is to shape the community to be your 'go to' for support, networking, education, inspiration and encouragement as we enjoy this adventure together.     Power Automate Community Team

Hear what's next for the Power Up Program

Hear from Principal Program Manager, Dimpi Gandhi, to discover the latest enhancements to the Microsoft #PowerUpProgram, including a new accelerated video-based curriculum crafted with the expertise of Microsoft MVPs, Rory Neary and Charlie Phipps-Bennett. If you’d like to hear what’s coming next, click the link below to sign up today! https://aka.ms/PowerUp  

Tuesday Tip | How to Report Spam in Our Community

It's time for another TUESDAY TIPS, your weekly connection with the most insightful tips and tricks that empower both newcomers and veterans in the Power Platform Community! Every Tuesday, we bring you a curated selection of the finest advice, distilled from the resources and tools in the Community. Whether you’re a seasoned member or just getting started, Tuesday Tips are the perfect compass guiding you across the dynamic landscape of the Power Platform Community.   As our community family expands each week, we revisit our essential tools, tips, and tricks to ensure you’re well-versed in the community’s pulse. Keep an eye on the News & Announcements for your weekly Tuesday Tips—you never know what you may learn!   Today's Tip: How to Report Spam in Our Community We strive to maintain a professional and helpful community, and part of that effort involves keeping our platform free of spam. If you encounter a post that you believe is spam, please follow these steps to report it: Locate the Post: Find the post in question within the community.Kebab Menu: Click on the "Kebab" menu | 3 Dots, on the top right of the post.Report Inappropriate Content: Select "Report Inappropriate Content" from the menu.Submit Report: Fill out any necessary details on the form and submit your report.   Our community team will review the report and take appropriate action to ensure our community remains a valuable resource for everyone.   Thank you for helping us keep the community clean and useful!

Users online (4,469)