cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
risingson
Level: Powered On

Forms not always triggering flows

I've setup a flow to trigger when a specific form is submitted and create a new task in Planner based on the form's submittal's details. I've gotten it to work once after having to add a "Z" at the end of the dynamic dates input. I then added another step to update the task details and now the flow does not seem to be triggering. Checking run history doesn't produce errors - it's claiming last it checked there was no data. But I definitely submitted forms before the latest "no data" check.Flow.pngFlow Run History.pngForms.png

8 REPLIES 8
BobCompere
Level: Power Up

Re: Forms not always triggering flows

I am having a similar issue with a flow triggered by O356 Form. It worked the 1st time and has not since.

risingson
Level: Powered On

Re: Forms not always triggering flows

I recreated everything (the form, the flow, etc.) and tried again. I can't even get it to work the first time with just the most basic information.

 

I have since submitted 4 responses to the form now and there's only one check in the run history, of which was skipped with the following information:

 

{
  "Pragma": "no-cache",
  "X-CorrelationId": "2004c50f-532b-49b9-be90-5555cc74fe9a,6b4ae163-e494-4606-b2ee-dbecd29d8b85",
  "X-UserSessionId": "2004c50f-532b-49b9-be90-5555cc74fe9a,3b642a3a-90c7-47e2-9165-fa3c5c4bfc29",
  "X-OfficeFE": "FormsSingleBox_IN_3,FormsSingleBox_IN_3",
  "X-OfficeVersion": "16.0.8506.6677,16.0.8506.6677",
  "X-OfficeCluster": "ea-000.forms.office.com,ea-000.forms.office.com",
  "retry-after": "3600",
  "OData-Version": "4.0",
  "X-Content-Type-Options": "nosniff",
  "Timing-Allow-Origin": "*",
  "Cache-Control": "no-cache",
  "Date": "Thu, 10 Aug 2017 01:50:08 GMT",
  "Location": "https://asia-001.azure-apim.net/apim/microsoftforms/ac92d97c-aa16-4510-bcc3-4f50-8af58983/trigger/formapi/api/forms('UhF3oHqnOUaxcDTVqfhj0aNEgCWmIslDhlrXTog_1-lUMzdFWTVaRVhWMVRGVUtIWFJMQTNUNzJRUy4u')/responses?triggerState=",
  "P3P": "CP=\"CAO DSP COR ADMa DEV CONi TELi CUR PSA PSD TAI IVDi OUR SAMi BUS DEM NAV STA UNI COM INT PHY ONL FIN PUR\",CP=\"CAO DSP COR ADMa DEV CONi TELi CUR PSA PSD TAI IVDi OUR SAMi BUS DEM NAV STA UNI COM INT PHY ONL FIN PUR\"",
  "Server": "Microsoft-IIS/8.5,Microsoft-HTTPAPI/2.0",
  "X-AspNet-Version": "4.0.30319",
  "X-Powered-By": "ASP.NET",
  "Content-Length": "0",
  "Expires": "-1"
}
Community Support Team
Community Support Team

Re: Forms not always triggering flows

Hi @risingson,

 

Thanks for the feedback.

There are threads talking about the same issue:

https://powerusers.microsoft.com/t5/General-Flow-Discussion/What-limit-of-Microsoft-Forms-Trigger/m-...

We have collected this and send the feedback through our channel.

But currently there is no helpful responses received.

I will post back once I got any helpful information that could explain the situation.

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
srizvi
Level: Powered On

Re: Forms not always triggering flows

I have a flow which triggers when a record is created on my Dynamics 365 CRM for the entity 'Planner'. The subsequent action to follow creates a task in Planner. The problem is the inconsistency of the trigger firing off. To test this inconsistency, I created five records on my CRM. The result should have been the creation of five planner tasks. Instead, only two of the five planner tasks were created. Is the fix currently under development? Can this be a problem of a server timeout because of too many requests in a short time? 

Anonymous
Not applicable

Re: Forms not always triggering flows

I'm seeing the same issue. 

With this bug, the flow configuration and debugging is extremely difficult.

 

The whole section Flow is thus unusable. If we cannot guarantee the consistency of results, then it cannot be used.

 

When will this issue be addressed?

 

Nemanja

TimSmith
Level: Power Up

Re: Forms not always triggering flows

Any update on this?

AnthonyW
Level: Power Up

Re: Forms not always triggering flows

@v-micsh-msftAny update?

BFS
Level: Powered On

Re: Forms not always triggering flows

@v-micsh-msft  Any updates here?

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 317 members 6,418 guests
Please welcome our newest community members: