cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Get Items Filter Query - Column does not exist

I have a flow that continues failing. The error message received is on the action "Get Items" from a SharePoint list. The error message says that the column does not exist or that it may have been deleted or moved by another user. 

 

The column name is '_date'. 

 

cameron0208_4-1597255098481.png

 

I have verified the internal name of the column in the SP list settings. As you can see in the image below at the very end of the URL 'Field=_date'

cameron0208_1-1597254886889.png 

cameron0208_2-1597254969890.png

 

I downloaded the output from the Get Items action to verify the column name. In the download, it shows the column name as 'OData_date'.

cameron0208_3-1597255014440.png

 

However, when changing '_date' to 'OData_date' in the flow, it still fails with the same error message about the column not existing. 

 

cameron0208_0-1597254854531.png

 

The column is visible in the main 'All Items' view

cameron0208_5-1597255354194.png

 

And the column type is 'Date and Time'

cameron0208_6-1597255375499.png

 

Here is the SP list (client names redacted)

cameron0208_7-1597255477147.png

 

Any help is much appreciated! 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Jcook
Super User
Super User

Hello @Anonymous 

 

From your output of get items. It looks like your column name is:

OData__date

 

There are 2 underscores.

 

Please try this and let us know results


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





View solution in original post

2 REPLIES 2
Jcook
Super User
Super User

Hello @Anonymous 

 

From your output of get items. It looks like your column name is:

OData__date

 

There are 2 underscores.

 

Please try this and let us know results


Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips,
tricks, and guides
FlowAltDelete





View solution in original post

Anonymous
Not applicable

Yep! This worked! Thank you so much! 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Users online (2,061)