cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
DemoMan
Level: Powered On

Get Items finds input returns blank Output

Good Morning Flowers, Happy Monday.

 

I'm refreshing this question because it has becomed a big issue for our department. And I'm hopping I can get pointed in the right direction with a bit more detail.

 

The issue is at follows: I have a flow that has a "Get Items" step, this step it is supposed to return a string that is set up on a previous step. The field I want is called "TSLink" and is a simple string or a date and an ID. "Get Items" receives the right Imput perfectly, but for some weird reason the output is always blank:

 

 

GetItemsBlankOutput.JPGeven if I add a "Filter Array" it outputs a blank value.

 

Is there an specific reason why "Get Items" would receive the Imput but not send it as an output?

My "Filter query" is findind the right item, so I know that is working. 

 

Thank You everyone

 

4 REPLIES 4
RezaDorrani
Level 10

Re: Get Items finds input returns blank Output

Hi @DemoMan 

 

The field I want is called "TSLink" and is a simple string or a date and an ID

 

What is the actual type of theis column? what is the data source?

 

If getitems returns empty that means your filter criteria is not returning any matches

 

DemoMan
Level: Powered On

Re: Get Items finds input returns blank Output

Hi @RezaDorrani 

 

Thank You for your help on this,

 

What is the actual type of theis column? what is the data source?

The field type is "Single Line of Text" the data source is another sharepoint list on the same site.

 

If getitems returns empty that means your filter criteria is not returning any matches

You are right, but the error occurs even when I hard code a string for an item I know exist.

 

Thank You

RezaDorrani
Level 10

Re: Get Items finds input returns blank Output

Hi @DemoMan 

 

Is it an error or is it that no data is returned by the action

Error and no data are 2 different things

Can you share some screenshots of your sharepoint list where TSLink data is held

 

 

Community Support Team
Community Support Team

Re: Get Items finds input returns blank Output

Hi @DemoMan ,

 

I have made a test on my side and don't have the issue that you mentioned.

Could you please share a screenshot of the sharepoint list and items?

 

Best regards,

Alice       

 

Community Support Team _ Alice Zhang
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 124 members 3,915 guests
Please welcome our newest community members: