cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Get Items from SharePoint not finding column

Hi all,

 

I've setup a flow to go through a SharePoint list and delete items from it where a column called "End_Date" is less than today's date.  The flow uses Get Items to find the List, and filter out End_Date values using an expression (all shown in the photo attached).

 

The trouble is, it can't find the column.  I've tried pointing it to another column (Start_Date), and it works.  I've tried re-ordering the columns in the SharePoint list incase it scans the column names alphabetically.  

 

Has anyone else experienced this happening?  

 

Thanks


Flow overviewFlow overview

 

 

 

 

 

 

 

 

 

 

 

 

 

 

List ColumnsList Columns

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User III
Super User III

Re: Get Items from SharePoint not finding column

Ok - then the issue is likely how you are referring to the column - you usually need to use the columns internal name.

Try this - create a Flow that has a button and a Get Items action and run the Flow. In the run history, look at the results of the Get Items action and note how the column is referred to - use that in your OData filter.
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

6 REPLIES 6
Highlighted
Dual Super User II
Dual Super User II

Re: Get Items from SharePoint not finding column

Did the column exist before you added the Get Items to the Flow?  Try removing the Get items action and anything else that uses the SharePoint connector.  Then re-add it into the Flow.  Also, make sure that the All Items view has the column you want included in the view.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Super User III
Super User III

Re: Get Items from SharePoint not finding column

@IanS 

If End Date is a calculated column then that is the issue - you won't be able to use a calculated column in the OData filter.

 

As a work around, you can re-create the calculation in your Flow.  For example, if the calculation for end date -s the starte date plus 30 days, take that into account in the expression in your filter.

 

If you need an example, please let me know. 

If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott
Highlighted
Frequent Visitor

Re: Get Items from SharePoint not finding column

The column did exist before setting up the flow.  I checked the All Items view, and it's definitely in there (the photo in the OP shows the all items view).  I've just re-created the flow from scratch and it's failed again

Highlighted
Frequent Visitor

Re: Get Items from SharePoint not finding column

Hi Scott,

The column isn't calculated in Sharepoint.  It's automatically added to the List from a separate Flow that takes data calculated in an excel spreadsheet.

The duration between the start and end dates isn't consistent either - so using a calculation in the expression (i.e. Start Date-30) wouldn't be as practicable.

Cheers,

Ian

Highlighted
Super User III
Super User III

Re: Get Items from SharePoint not finding column

Ok - then the issue is likely how you are referring to the column - you usually need to use the columns internal name.

Try this - create a Flow that has a button and a Get Items action and run the Flow. In the run history, look at the results of the Get Items action and note how the column is referred to - use that in your OData filter.
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Scott

View solution in original post

Highlighted
Frequent Visitor

Re: Get Items from SharePoint not finding column

Thanks Scott - that worked. The Flow wanted a different name for it (in this instance it was "Date"). I had to make one minor change to the debugging flow you recommended though - I had to specify what view I wanted the Get Items action to get, otherwise it didn't return any column info. Thanks for all the help everyone!

Helpful resources

Announcements
secondImage

August 2020 CYST Winners!

Check out the winners of the recent 'Can You Solve These?' community challenge!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (4,583)