cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ricardo111
Helper I
Helper I

Get a Row (Excel business) - matching identical value from two excel tables - Now Row found with id.

Hello! I'm very perplexed by this!

 

Flow works as follows

 

1 - Manual Trigger

2 - Get a Row (excel): Gets first row of a table that includes a column title 'phone' with a phone number from an excel table (format general)

3 - Get a Row (excel) - different sheet/table to the first.  

Search by:

key column name: Phone

Value: variable from  the 2nd action (phone from the first sheet).

 

returns: No row was found with Id ...

 

The data from the 1st action:

 

{
,
  "phonepda""�6141111117",
 
}
 
The 3rd action returns status 404, id not found.
 
But the second sheet DOES contain exactly the same phone number. The format of the phone number in BOTH sheets (tables) is formatted as 'general'
 
I re-ran the flow using email and this worked fine.
But not with the phone number.
 
 
 
1 ACCEPTED SOLUTION

Accepted Solutions
Ricardo111
Helper I
Helper I

In the end I switched to using email address as a unique identifer (key).

Thanks for trying to help.

There is a glitch in PA on this issue of cross-checking a 'number'  between one table and a different table in excel, despite identical formatting (whether formatted as a number or general or text).

View solution in original post

15 REPLIES 15
Mira_Ghaly
Dual Super User
Dual Super User

@Ricardo111 

There looks like there is a special character in the phone field in the first sheet

Mira_Ghaly_0-1664922513671.png

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
Ricardo111
Helper I
Helper I

Hi Mira, Ah, 

 

Thank you for pointing out the issue.

 

I'm trying to find what character has been added ... the excel sheet data does not appear to have anything other than the number (formatted as general).

 

Any ideas?

I'll report back also if I find the answer!

@Ricardo111 

Trying to use the trim expression on the column.

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
Ricardo111
Helper I
Helper I

I tried trim but still get the "?6144444444"

The original variable is sent to the sheet from a power automate desktop.

This variable is the output of a python script.

The variable has one line , is a 'text' string, and has the number ... and also has whitespace removed.

There seems to be some non whitespace characters hidden somewhere on the table.

Ricardo111
Helper I
Helper I

.... A bit more information might help!

The following is the JSON response for the PA flow that receives the power automate desktop flow. Some variables have ?in them and others do not.

The PAD flow is sent to PA with 'do not encode' selected.

 

"body": {
        "name""�Rob",
        "DOB""14/11/1974",
        "First_Name""mark",
        "name_second""�Tester",
        "phone""�61444444444",
        "NOK""�Sasha",
        "Photo""�Yes",
        "emailoutput""robbtest@hotmail.com",
        "locationoutput""SESC",
        "googlelink""https://g.page/r/CQaYadsfadsfasfdAI/review",
        "key""keasdfasdfadfasdfadsf"
    }
}
Ricardo111
Helper I
Helper I

I tried decode using compose

still get (I've changed numbers so hope this isn't confusing)

"�6144444444"
Ricardo111
Helper I
Helper I

ps I did try 'trim' on excel but the ?still appears (but trim only removes whitespace and there isn't any)

@Ricardo111 

Okay in the flow try to remove the first character

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
Ricardo111
Helper I
Helper I

Unfortunately this does not work.

Compose with

substring(outputs('Get_a_row')?['body/Phone'],2,10)

I'm totally baffled to be honest it's like there is a bug.

@Ricardo111 

Did you check the history for the value in ? Just try using the below

substring(outputs('Get_a_row')?['body/Phone'],1,10)

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
Ricardo111
Helper I
Helper I

Ah yes I did that earlier, the following returns the same number eg 61444444444

substring(outputs('Get_a_row')?['body/Phone'],1,10)

 

Ricardo111
Helper I
Helper I

Just taking a step back, see screenshot of:

get a row (excel) ‘raw output’

this data is derived from the first excel table and the ‘Phone’ number used as the key value in the second table.

Paexamole.png

 

Can you try to copy the values in the phone column into another column and rename it to be the same, delete original column and try again.

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here
Ricardo111
Helper I
Helper I

Good Idea I’ll report back tomorrow

Ricardo111
Helper I
Helper I

In the end I switched to using email address as a unique identifer (key).

Thanks for trying to help.

There is a glitch in PA on this issue of cross-checking a 'number'  between one table and a different table in excel, despite identical formatting (whether formatted as a number or general or text).

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Users online (5,460)