cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rogermiddleton
Helper II
Helper II

Get attachments broken

Hi everyone,

 

I have a Flow which sends an email when a new item has been created in a SP list. It uses an array to sent all the attachments in 1 e-mail and the e-mail is sent from a shared mailbox. The attachments in the email are corrupted, but can be openend when approached through the SP list.

Can it have something to do with the settings in the SharePoint List? The mail is sent to 2 owners of the list with full rights. If it has to do with SP list settings, can you help me with what to change?

 

Thanks!!

 

Flow1.PNGFlow 2.PNG

 
 

 

1 ACCEPTED SOLUTION

Accepted Solutions
yashkamdar
Super User II
Super User II

Hello Team,

 

I found your issue out and resolved the exact same issue a couple of days ago for another user.

https://powerusers.microsoft.com/t5/Building-Flows/Add-SP-attachements/m-p/714463#M97510

 

Microsoft has recently changed the way in which Attachment Content is now rendered.

 

You no longer need to parse the "Attachment Content" and filter out the $content property inside it or pass the "body" property to get meaningful content, just adding the "Attachment Content" directly in your Append to array variable will directly give you the meaningful file content.

 

So in the Append to array variable make the following change, instead of body pass the attachment content as below -

 

Capture.PNG

 

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

3 REPLIES 3
yashkamdar
Super User II
Super User II

Hello Team,

 

I found your issue out and resolved the exact same issue a couple of days ago for another user.

https://powerusers.microsoft.com/t5/Building-Flows/Add-SP-attachements/m-p/714463#M97510

 

Microsoft has recently changed the way in which Attachment Content is now rendered.

 

You no longer need to parse the "Attachment Content" and filter out the $content property inside it or pass the "body" property to get meaningful content, just adding the "Attachment Content" directly in your Append to array variable will directly give you the meaningful file content.

 

So in the Append to array variable make the following change, instead of body pass the attachment content as below -

 

Capture.PNG

 

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

Hi @yashkamdar ,

 

This works like a charm! Thank you very much.

 

Kind regards,

 

Roger Middleton

Hello @Rogermiddleton ,

 

Absolutely my pleasure that I could help you out. 

 

Cheers 😀

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Users online (16,676)