cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Regular Visitor

Get item after "For a selected item" fails for owner

I'm trying to get an item that was selected in a SharePoint list.

It always fails when i try to run that flow with the user that created the flow, the list and the item, is site owner and global admin.

I however added a new user as owner of the flow and when he runs the flow everything runs smoothly, independent of who created the item. If i change the trigger to "Item created" everything also works.

I have created two Testflows, one with selected (selected) and one with created (created) trigger.

This is the fail body:

{
  "error": {
    "code": 502,
    "source": "flow-apim-europe-001-francecentral-01.azure-apim.net",
    "clientRequestId": "8a0ce71a-a731-40dd-96d6-ca240af5caec",
    "message": "BadGateway",
    "innerError": {
      "message": "Gateway on endpoint '<ii>sb://wabi-west-europe-relay7.servicebus.windows.net/65cf12e0-cc9e-4b3e-b107-d97f682443cf/</ii>' is unreachable.\r\nclientRequestId: 8a0ce71a-a731-40dd-96d6-ca240af5caec",
      "status": 502,
      "source": "https://sharepointonline-ne.azconn-ne.p.azurewebsites.net/datasets/https%253A%252F%252Fandritztest.sharepoint.com%252Fsites%252FGroupprovisioning/tables/48468cda-f186-4d9f-bcb3-0522ee8230f7/items/9",
      "errors": []
    }
  }
}

Can anybody help here, seems quite obscure.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @SebAndritz,

 

Can you provide a full screenshot of your Flow configuration?

It seems that the link you provided is currently inaccessible.

What do you mean is that when you trigger Flow as owner, an error occurs, and other users act as owner to trigger Flow but there is no problem?

If the error code 502 appears, the failure may be temporary or transient. Please Click or tap Resubmit to try the flow again.

If the problem still exists, please let me know and provide more details, we would provide a proper workaround for you.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Community Support
Community Support

Hi @SebAndritz,

 

Can you provide a full screenshot of your Flow configuration?

It seems that the link you provided is currently inaccessible.

What do you mean is that when you trigger Flow as owner, an error occurs, and other users act as owner to trigger Flow but there is no problem?

If the error code 502 appears, the failure may be temporary or transient. Please Click or tap Resubmit to try the flow again.

If the problem still exists, please let me know and provide more details, we would provide a proper workaround for you.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi,

 

seems like the Problem was temporary, today my flow was deactived and permissions were invalid. After reactivating both the flow works as expected.

UpdateFlow.png

The Flow did fail if I started it with my account, with a normal user account which also was added as owner, it ran normally.

The only advisory i found was SP148979 which i guess could be related to the issue but i don't want to jump to any conclusions.

 

Thanks for the support!

Kind regards,

Sebastian

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Top Kudoed Authors
Users online (8,005)