cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Get items sometimes does not get more than 100 items

Hello, 

 

I have this flow that : 

* take a list of items in a list

* filter another list based on the value gotten in the 1st one

* adds some value from this 2nd list.

 

I have 12 value in the first list, that I get thanks to a "Get items" flow

After that, i set up a loop on a 2nd list with : 

* Get items, and a condition fieldA eq 'value from get items 1'

 and then i loop again on those values to make a sum of some other field.

 

My issue is : my Get items 2 can often get more than 100 values so I went to the setting, activated Pagination, and put a limit at 5000 (the maximum).
However, when I run the flow, for 2 out of 12 values from the 1st list, the Get items 2 get only 100 values, and I don't understand why...
The block is the same, parameter is identical, I have checked several times that my data were filled well.
I'm at loss.

Does any of you have an idea of what is the issue, and how to get it work properly ?

 

Thanks a lot

5 REPLIES 5
Highlighted

Re: Get items sometimes does not get more than 100 items

Hi @Anonymous,

 

Could you try doing the same using the REST API in your browser. So somethign like this:

 

https://mytenant.sharepoint.com/_api/web/lists/GetByTitle('The name of your list')?$filter=Title eq 'Whatever'

 

It should return the same number of items.

 

Highlighted
New Member

Re: Get items sometimes does not get more than 100 items

Hi @Pieter_Veenstra,

 

(Don't know why I had to create a new user... weird).


First of all, thanks for the reply.

 

I'm not sure to understand this REST API thing : where should I put the example you've provided  me ?

Highlighted

Re: Get items sometimes does not get more than 100 items

Straight in the browser. It should give you xml with data back.

Highlighted
Anonymous
Not applicable

Re: Get items sometimes does not get more than 100 items

It does not seem to work the way I do it 😞

@Pieter_Veenstra

It says my list does not exist.
I've tried with its "display name" as well as the "UID" name (perhaps I made a mistake ?)

To understand better : how will I then include that in my Flow to make it work ?

 

Thanks

 

 Edit : 

here is my error message : (I changed the url of course)

 

<m:error xmlns:m="http://schemas.microsoft.com/ado/2007/08/dataservices/metadata">
<m:code>-1, System.ArgumentException</m:code>
<m:message xml:lang="en-US">
List '41c0d595-9570-4e19-a88f-4f8054a942a8' does not exist at site with URL 'https://MYSITE.sharepoint.com'.
</m:message>
</m:error>
 
Highlighted

Re: Get items sometimes does not get more than 100 items

In the following url you should use the title of the list/library

 

https://mytenant.sharepoint.com/_api/web/lists/GetByTitle('The name of your list')/iterms?$filter=Title eq 'Whatever'

 

 

The guid you can use by:

 

https://mytenant.sharepoint.com/_api/web/lists/('GUID')/items?$filter=Title eq 'Whatever'

 

Also does your list live in the root site collection? you might have to add subsites etc.

 

https://mytenant.sharepoint.com/sites/sitename/_api/web/....

 

 

Helpful resources

Announcements
FirstImage

Microsoft Ignite 2020

Check out the announcement of Power Platform content at Microsoft Ignite!

thirdImage

Experience what's new for Power Automate

Join us for an in-depth look at the new Power Automate features and capabilities at the free Microsoft Business Applications Launch Event.

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (10,523)