cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ktmchugh
Level: Powered On

Getting 404 Error When File Definitely Exists

Hi,

 

I have a very simple flow, designed to regularly create a table in an xlsx file.  The flow works fine the first run. However, I need it to run once/ month, each time on a new upload of an xlsx file of the same exact name. I find that when I delete and upload a new copy of the file, I get a 404 error. If I go in and manually change the file name, etc in the flow it works fine. So something is changing in the xlsx name that I can't see. Is there a creative workaround for this? 

CreateTable.JPG

 

 

Thank you!

katie

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Gristy
Level 10

Re: Getting 404 Error When File Definitely Exists

Are you typing in the value, or selecting with the folder icon?

 

If you are picking from the folder icon, try typing it in, or first putting the value in a compose and then inserting as dynamic data.

 

Also a screenshot of the errors may be handy.

View solution in original post

3 REPLIES 3
Highlighted
Gristy
Level 10

Re: Getting 404 Error When File Definitely Exists

Are you typing in the value, or selecting with the folder icon?

 

If you are picking from the folder icon, try typing it in, or first putting the value in a compose and then inserting as dynamic data.

 

Also a screenshot of the errors may be handy.

View solution in original post

Community Support Team
Community Support Team

Re: Getting 404 Error When File Definitely Exists

 

Hi @ktmchugh ,

 

Once the previous selected file has been deleted, you need to reconfigure the Create table action and re-select the new file via File browse.

Just copying an Excel file with the same name does not work, because the connection between the action and the current file is not established, so a similar error occurs.

Hope it makes sense.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
ktmchugh
Level: Powered On

Re: Getting 404 Error When File Definitely Exists

Hi @Gristy ,

 

Thank you. I was selecting with the folder icon.  I tried both options and the compose option worked!! Fantastic. Your help is much appreciated!  This is the solved flow:

 

Solution.JPG

 

Helpful resources

Announcements
thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Kudoed Authors (Last 30 Days)
Users online (5,700)