cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Getting 'Expression Evaluation Failed' when working with Forms as trigger every time

Hi Everyone,

 

I'm building a approval flow for sharing documents with a specific user. The trigger is set to be every new response in a specified form.

 

When using the 'get list of response IDs' in the apply for each field, I always get this error:

 

ExpressionEvaluationFailed. The execution of template action 'Auf_alle_anwenden' failed: the result of the evaluation of 'foreach' expression '@triggerOutputs()?['body/value']' is of type 'Null'. The result must be a valid array.

 

What am I doing wrong? I'm not very familiar with flow, we just started playing and testing with it. I did the same as in the template library, getting response IDs first as apply for each and then go on from there. Until today it worked fine.

 

Thank you,

NiclasN

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Getting 'Expression Evaluation Failed' when working with Forms as trigger every time

 

Hi @NiclasN ,

 

Please try this configuration:

143.PNG

You could remove Apply to each and try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Highlighted
Post Prodigy
Post Prodigy

Re: Getting 'Expression Evaluation Failed' when working with Forms as trigger every time

Hi @NiclasN,

 

it looks like wrong syntax.

Try to use triggerOutputs()?['body']?['value'] 

Highlighted
Community Support
Community Support

Re: Getting 'Expression Evaluation Failed' when working with Forms as trigger every time

 

Hi @NiclasN ,

 

Please try this configuration:

143.PNG

You could remove Apply to each and try again.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
New Member

Re: Getting 'Expression Evaluation Failed' when working with Forms as trigger every time

Hi @v-bacao-msft,

 

good idea, I'll try this configuration for the next flow. I just tried recreating the workflow from scratch and for some reason it works until now.

 

1.JPG

 

Helpful resources

Announcements
firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

Join the new Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Top Kudoed Authors
Users online (7,660)