cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Getting a Bad Request error when a card is added to a Trello board

I'm receiving a Bad Request error when a card is added to a Trello board.  Let me know what else you need to troubleshoot.

 

1.PNG

 

1 ACCEPTED SOLUTION

Accepted Solutions
Brad_Groux
Community Champion
Community Champion

A 400 error is a "bad request" or "not found" error. I'd verify that your Trello connector is properly working, by going to the Data > Connections area of Flow: Connections.png

Then on the Trello connector click the ellipsis to select Delete and/or Switch account to re-enter your login credentials for Trello:Verify.png

Also, on the Trello steps within your Flow, insure that you are utilizing the correct connection, via the My connections popup from the ellipsis:

Credentials.png

Again, this may be an access or authetnication issue, so insure that on the Trello side everything is working as intended and the account has full read/write access to the Trello boards.

If that doesn't work, if you could provide an expanded screenshot of your Flow and steps, and of any detailed error messages you're receiving we could likely better assist you.

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

View solution in original post

5 REPLIES 5
Brad_Groux
Community Champion
Community Champion

A 400 error is a "bad request" or "not found" error. I'd verify that your Trello connector is properly working, by going to the Data > Connections area of Flow: Connections.png

Then on the Trello connector click the ellipsis to select Delete and/or Switch account to re-enter your login credentials for Trello:Verify.png

Also, on the Trello steps within your Flow, insure that you are utilizing the correct connection, via the My connections popup from the ellipsis:

Credentials.png

Again, this may be an access or authetnication issue, so insure that on the Trello side everything is working as intended and the account has full read/write access to the Trello boards.

If that doesn't work, if you could provide an expanded screenshot of your Flow and steps, and of any detailed error messages you're receiving we could likely better assist you.

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

v-bacao-msft
Community Support
Community Support

Hi @Anonymous ,

 

I noticed that you filled the trigger with a Board Name instead of a Board Id.

What is needed here is The unique id of the board.

19.PNG

You could configure the Board Id in two ways:

  1. Select the board from the drop down list.

21.PNG

  2. Get the specified board's Id by List boards action first. Then click Enter custom value to configure Board Id in the trigger.

20.PNG

 

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Before, I had two different Trello accounts for testing so I just created a new board for "test" to avoind any confusion as to what account I was using.  

 

When I created the new board, Trello also added "Power Apps" back.  (I deleted it for troubleshooting.)  I believe Trello needs this for the Flow I'm using.  (See pic.)Power Apps 2.PNG

 

 


@Anonymous wrote:

Before, I had two different Trello accounts for testing so I just created a new board for "test" to avoind any confusion as to what account I was using.  

 

When I created the new board, Trello also added "Power Apps" back.  (I deleted it for troubleshooting.)  I believe Trello needs this for the Flow I'm using.  (See pic.)Power Apps 2.PNG


Yup, that looks to be it! Glad you figured it out... and trust me, you're not the only one who has done this. I work across multiple tenants, with several 3rd party online services and an online and offline SharePoint farm and I am always using the wrong account... getting stuck for a few minutes, and then I'm like, "Oh, yeah - check the account!" 

That's both the beauty and the frustrating aspect of Flow. It connects to SO MANY THINGS and empowers you to do SO MANY THINGS, but the more complex you build it, the more ways it can go wrong too!

Hello Where do I do this in Flows?

Than ks!

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (2,990)