cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
DLGross
Level 8

Getting data from O365 Service API- Select Operation

I'm trying to use some tips from @spg-john-liu to get data from the O365 Service Health API. I added a Select operation but the fields for the Dynamic values picker are not available, see below selectBody.png

Also, after I did a Test run, the expression I entered was replaced as follows selectValue.png

 I don't understand what is going on, can someone please explain why this would happen and how to fix?

Dean Gross

Office 365- MSCA
SharePoint - MCSE
Microsoft 365 Enterprise Administrator Expert
1 ACCEPTED SOLUTION

Accepted Solutions
DLGross
Level 8

Re: Getting data from O365 Service API- Select Operation - UI Bug found

I have figure out what is going on and it appears to be a bug in the Map functionality. 

When I attempt to map a value it does not get resolved in the UI, e.g. Message type belowSelectAttributes1.png

Changing the UI to  Text Mode causes the JSON to have 2 @ symbols instead of one, see below

SelectAttributes2.png

 

If I remove one of the @ symbols, and switch back to the Key Value mode, the UI renders the value as expected, SelectAttributes3.png

The Dynamic Content never does show the fields that are being returned from the HTTP Get prior to the Select operation. 

 

Dean Gross

Office 365- MSCA
SharePoint - MCSE
Microsoft 365 Enterprise Administrator Expert

View solution in original post

1 REPLY 1
DLGross
Level 8

Re: Getting data from O365 Service API- Select Operation - UI Bug found

I have figure out what is going on and it appears to be a bug in the Map functionality. 

When I attempt to map a value it does not get resolved in the UI, e.g. Message type belowSelectAttributes1.png

Changing the UI to  Text Mode causes the JSON to have 2 @ symbols instead of one, see below

SelectAttributes2.png

 

If I remove one of the @ symbols, and switch back to the Key Value mode, the UI renders the value as expected, SelectAttributes3.png

The Dynamic Content never does show the fields that are being returned from the HTTP Get prior to the Select operation. 

 

Dean Gross

Office 365- MSCA
SharePoint - MCSE
Microsoft 365 Enterprise Administrator Expert

View solution in original post

Helpful resources

Announcements
firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (3,822)