cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

Hi there,

 

I get this error mentioned in the subject line for the Flow that is used for sending Approval. I have checked the O365 Admin and Azure AD user profile and there is just one primary email ID/ profile for the affected user name. Looking for suggestions, please.

10 REPLIES 10
Community Support Team
Community Support Team

Re: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

Hi @  MB3,

 

Could you please share a screenshot of the configuration of your flow?

Which action would run failed with the error message that you provided?

 

Please share more details so we could provide a proper workaround for you.

 

 

Regards,
Alice Zhang

MartinM
Level: Powered On

Re: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

Hi,

 

I got the same error suddenly. 

I'm testing with a very simple, 1-step approval flow on files stored in a SharePoint library.

The name of the approver is taken from a field of the library.

Flow1.jpgFlow2.jpg

 

The approval actions fails with the error message:

The request failed. Error code: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for ....

 

Any suggestions what could be wrong?

 

thx

Martin

agzertuche
Level: Powered On

Re: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

I faced the same problem, but modifying the AD accounts to avoid this issue is not a solution for me.

So, what I end up doing was to assign the approval to the "Id" of the user instead of the "email", as follows:

1. Before the approval action, add a new Office365 "Get user profile" action to get the "Id" of the account, then look for the account using your approver email.

2. On the approval action, update the "Assign to" field to the outcome of the "Id" field from the previous action

3. Save and test the flow

 

image.png

 

 

siegard
Level: Power Up

Re: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

Ok, I'm having the same error and I swear I've used your work around in the past but now I'm trying to re-create an old workflow I had and when I use the "ID" attribute I get this.

 

BadRequest. The request failed. Error code: 'InvalidApprovalRequestor'. Error Message: 'The approval requestor must be a single, valid user account within your organization.'.




QuentinY
Level: Powered On

Re: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

Hello

I also encounter this issue, any idea of it

Madhatter704
Level: Powered On

Re: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

I tried this fix as "Get Manager" and "Get User Profile" as a step before the approval and it doesn't work.  I get the error "Assign To" field must be an email.  When I switch the assign to field to Mail from the Get User profile step it creates the exact same error again.

"BadRequest. The request failed. Error code: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users"

 

Capture 3.PNGCapture 2.PNGCapture.PNGAny help is appreciated.

 

Thanks 

Madhatter704
Level: Powered On

Re: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

Invalid request error, after using 'ID' in the 'Assigned To' field.

QuentinY
Level: Powered On

Re: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

The issue fixed on my side now.  In my scenairo, fo work convincence, tagart user used to add his email address on another domain ID.(we seperate privilaged ID and normal user ID).

To make the email address unique, I use a dummy mail address to override one of ID. the issue fixed when I try it afte 24hrs.

Hope this would help.

kmw1130
Level: Powered On

Re: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

I'm having the same issue, but when I look in Azure AD, I do not see any duplicates.  It seems to be a sync issue.  The error gave me two GUIDs "Found multiple matching users ('GUID #, GUID#') for first.last@site.com".  Are these GUIDs from AD?

Madhatter704
Level: Powered On

Re: 'GraphUserDetailByEmailMultipleFound'. Error Message: 'Found multiple matching users for abc

I'm still having the exact same issue and splitting off to a separate domain isn't an option.  Does anyone have a working solution?  I've even tried the Get User Profile and use the ID and it still results in the same error.

 

 

Flow Failure Multiple Matching Users.PNG

 

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Watch the event on demand for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020.

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 165 members 4,684 guests
Please welcome our newest community members: