cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BSacchini
Frequent Visitor

HELP BUILDING FLOW TO RECORD FORM RESPONSES THAT HAVE ATTACHMENTS

Hello, I am trying to set up a flow where I can get a specific form response and record all the answers automatically into a sharepoint list. 

So far I have been susccesful in having answer recorded into my lists columns, however I am having some trouble attaching to each list item documents uploaded to the form. The weird thing is that it sometimes works and generates the attachment to the item and sometimes it just does not work ant the item is created w/o attachment.

 

My Flow is structured as you can see below:

image.pngimage.png

 

The schema for the Parse JSON action is the one below:

 

image.png

The problem arises (sometimes but not all the time) in the step "apply to each 2" specifically in the action "Get file content using path". I dont really know why. 

 

Please help!

 

2 REPLIES 2
ham
Community Support
Community Support

Hi,

 

1. Where is your uploaded files getting saved when the form is submitted.

2. Have you set a size limit for the files.

3. Can you check if the files are available on the location which you are specifying on the get file content using path step.

4. Check the flow run history to know if there are any errors.

 

Suggestion to try : Remove the Apply to each condition and add the Get File Content using Path action after Parse Json.

 

Best Regards,

Harish M

Please mark as verified if the answer is helpful. Welcome to join hot discussions in Dynamics 365 Forums

BSacchini
Frequent Visitor

Hello Harish, thanks. 

to your questions: 

1) they are getting saved into a path App/forms/list name/question folder within the team site where the form belongs.

 

2) there is a file size limit in the form (100 mb). The files uploaded when the flow runs w/o error as well as when it runs with errors do not exceed this limit.

 

3) yes. I actually check to see if files are available in the path and they are.

 

4) the flow run history has errors and successful runs. The error, when it shows, is always at the the “get file using path” step.

 

regarding your suggestion, I’ll try removing the apply to each to see if it solves my problem. Although I understood such condition was needed in case there where more than 2 files been uploaded in the form.

 

any other suggestion?

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

MPA Licensing.jpg

Ask your licensing questions at the Power Automate AMA!

Join Priya Kodukula and the licensing team, super users and MVPs to find answers to your questions on Power Automate licensing.

Users online (2,751)