cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

HTTP Action "Unable to connect to remote server"

Hi community!

 

This is my first time posting so please let me know if there's any information I should've included. 

 

So my flow has been working excellently since I created it maybe 7 months ago, I work in recruitment so my flow is triggered when an email comes in when someone has applied for a job, the flow checks if the emails attachment contains 'Resume' in its name, if it does, I send a HTTP POST request with the emails information to my website that runs Php, it interprets the data and puts it into my DB, then I send a 200 status code if everything went well.

 

In the past 2 weeks I've noticed I've been getting two different errors, when I re-run either the failed flow or a previously successful flow I get the second error.

1. "Forbidden." with a status code of 403.

2. "BadRequest. Http request failed with status code 'ConnectFailure' and status message: 'Unable to connect to the remote server'."

 

It's been doing my head in because nothing has changed on my web server that could've caused this and my code is written so it will only send a 200 status code unless the token in the URL is incorrect, in that case it will return a 401 status code.

I've tried turning on some debugging on my website and even tried pointing my HTTP POST to a php script that only returns a 200 status code but I get the same error every time. From what I can tell the request never actually makes it to my script. I've tried sending an identical HTTP request with PostMan and it went through successfully.

 

I've copied in all the information I can think to include, I would really appreciate if anyone has some tips or suggestions that might help me resolve this.

 

Flow Structure:

Automated Flow

 

Error Message 1:

Error Message 1

Error Message 2:

Error Message 2

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Regular Visitor

Re: HTTP Action "Unable to connect to remote server"

My issue has been resolved!

 

It turned out that it wasn't an isolated flow issue, The company hosting my web server had misconfigured some BitNinja security settings which resulted in greylisting a wide range of IP's which included Microsoft Flow.

 

Hope this helps anyone who encounters the same issue.

View solution in original post

4 REPLIES 4
Highlighted
Regular Visitor

Re: HTTP Action "Unable to connect to remote server"

If anyone ends up having the same issue, I think I must have hit the 2000 run limit on the free flow subscription.

 

It's been working fine since the month rolled over.

Solution Sage
Solution Sage

Re: HTTP Action "Unable to connect to remote server"

Hi @MattPeters ,

Can the flow run successful in this month(May) now?

If yes, I think the cause is what you have said that you have hit the 2000 run limit.

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

Highlighted
Regular Visitor

Re: HTTP Action "Unable to connect to remote server"

Hi @v-zhos-msft ,

 

Thanks for getting back to me!

 

I thought the 2000 flow limit must have been the cause because it seemed to work fine on the 1st May, but today it's just given me Error 1 "Forbidden 403" again. I am certain we haven't gone over the 2000 flow limit.

 

I'm not very experienced with HTTP requests so this may just be the typical response for a 403 status, but I notice every time it returns 403 status code, in the output header that returns to my flow it has: 

"Server" : "Apache/2.2.16,(Debian)"
 
but in the past when it returns a 200 status code, the output header returns:
"Server" : "nginx"
 
I've written a test script in php which only will return a 200 OK status, I just tried using a free website that to test it (https://reqbin.com/), strangely this website got the same 403 status code as my flow, but when I use Postman I get the 200 status code. Feel free to send requests to this url to test it: https://www.capitaltalent.com.au/maintenance/flow_action.php
 
Any tips on how to debug this?
Highlighted
Regular Visitor

Re: HTTP Action "Unable to connect to remote server"

My issue has been resolved!

 

It turned out that it wasn't an isolated flow issue, The company hosting my web server had misconfigured some BitNinja security settings which resulted in greylisting a wide range of IP's which included Microsoft Flow.

 

Hope this helps anyone who encounters the same issue.

View solution in original post

Helpful resources

Announcements
firstImage

Now Live: Power Virtual Agents Community!

We are excited to announce the launch of Power Virtual Agents Community. Check it out now!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Users online (11,008)