cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
aboldi
Level: Power Up

HTTP GET call not returning value

Hey guys,

 

I'm doing a simple http GET call to a bank's API in order to pull out an authoization token for further HTTPs.

 

The odd thing is that Flow seems to be scrubbing out the 'Authorization' header from the return. In other areas (the bank's dev area, Nintex) Authorization is present, but for some reason it is not being returned by Flow despite returning a 200 code. Other expected headers are there, but the only useful one (Auth) is missing!

 

One thought was that perhaps Authorization wasn't returned because it's a pretty long string (220 chars).

 

Anyone seen anything similar? Or have any suggestions? I'm mighty confused and can't really progress without the Auth token so any help greatly appreciated!

 

Thanks,

Scott

1 REPLY 1
SamPo
Level 8

Re: HTTP GET call not returning value

Have you tried running the same call from Postman? Is the auth header included there?

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 85 members 4,505 guests
Please welcome our newest community members: