cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
MStoltzfus
Regular Visitor

HTTP Request-Triggered Flow Works until I try to send the data, then I get a BadRequest Error

So this is a weird issue. I have a Flow that is triggered when an HTTP Request is sent from a form on my webpage. It does some data operations  using "Select", "Compose", and "Parse" steps to format the JSON data into workable properties that I can put into something like a Teams or Email message, or, more ideally, pass the data over to the Common Data Service/CRM.

 

However, when I add a step to send the data via message or save it to the Common Data Service, and test the Flow by triggering manually (submitting a form through my webpage), I get a BadRequest Error in the first trigger step (which you can see in the screenshots below).  When I remove the last step, the flow works just fine. Any ideas why this is happening? If I test it by triggering using previous run data, the flow works perfectly. But I will reiterate, when I test it with no send/save block, it works fine when triggered manually.

 

With the final step (see the screenshot below for what is in the step)

image.png 
image.png

 

image.png

 Flow runs completely fine without that final step (literally the only the thing I did was delete the final step)

image.png

 

2 REPLIES 2
PrasadAthalye
Super User
Super User

@MStoltzfus - I see that you have response as a parallel action. Did you configure it to run on failure only? It appears to me that you are returning a response and also trying to perform some action at the same time but by adding a delay. Can you try to put Response action after the post message action and see if error goes away?

 

Like and mark this as action if it resolves your issue.

Please Like and Mark this as Answer if it resolves your Issue.

Power Automate Community

@PrasadAthalye Moving the response does not change the outcome. If there's a send message/make record step, it will always fail. I had moved it to parallel and added a delay to the other leg just to test it, but the issue continued.

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (58,900)