cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ONYXJas
Advocate IV
Advocate IV

Having trouble with Run After configuration preventing a succeeding step from running

I have a flow in which the success or failure of one step in an Apply to Each loop should not prevent the following step from running, however, all subsequent steps seem to get skipped regardless.  Does anyone have any ideas?

 

The logic looks like this

 

Apply to Each (excel table) row

{

   Add to Group [rowUser UPN]

      {

       On success: set rowOutcome = "Group load successful"

       On fail: set rowOutcome = "Group load failed"

       }

Update Excel (current) row

     {

       [Outcome]= [rowOutcome]

     }

}

 

I get the correct run-after action for the Add to Group action (success or fail), but nothing after that runs.  What gives?

 

FLOW-OutcomeCheckStep failing-20200724.jpg

I would expect the compose + update steps to run regardless of the prior run-after branches but the compose step fails and I do not get the rowOutcome updated.

 

Compose step Run-After is configured as follows

FLOW-OutcomeCheckStep RunAfterConfig-20200724.PNG

The result in Run History is

FLOW-OutcomeCheckStep RunAfterStateError-20200724.PNG

 

Originally I had no Run After configured for this step, since the outcome of the previous steps does not matter, I want the compose and succeeding update to run regardless, but it skipped in that test too.

4 REPLIES 4
Mira_Ghaly
Dual Super User II
Dual Super User II

@ONYXJas 

Can you paste screenshots of your flow please?

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Hi there, I have added a screen shot of the troublesome bit as requested - thanks for your input on this 🙂

Mira_Ghaly
Dual Super User II
Dual Super User II

@ONYXJas 

If the Compose step fails that means that there is an issue in the Compose step, can you check the flow history run and add screenshot for it?

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Screenshots of the compose Run-after config and results are added to my post

Helpful resources

Announcements
MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

Top Solution Authors
Users online (56,436)