cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Stone_Database
Level: Powered On

Help with appending a Sharepoint List (Create Item) from an Excel Table (List Rows Present...)

Hello!

 

What I'm trying to do:

 

Use a Flow to First delete then add items to a Sharepoint list for each row in an excel table that's stored on OneDrive Business. The delete part is working fine so I'm focusing on what isn't, the appending.

 

What I need help with:

 

Here's what I have set up for this one:

 

overview.PNG

 

The list rows setup:

list_rows.PNG

 

Then the Apply to Each:

 

toeach.PNG

 

Okay, here's the problem. It does seem to be pulling in all the columns on the List, so that's perfect. It also is pulling all the columns on the Excel (they're all suggested by dynamic content), but the dynamic content is only showing up fro the first two fields (in this case, "Region" and "Director", the other fields do not list the dynamic content. I manually creadted them like this:

 

items('Apply_to_each_2')?['Column Name'] 

 

And it is not recongizing that as valid. I have the exact same column name on the Sharepoint List (created through List Settings, so it is a true name), and the excel sheet. What I don't get is that it is pulling in these suggestions on those first two fields, just not the later ones, see below:

 

working.PNG

 

What do I need to change?

 

Thank you for the assistance.

2 REPLIES 2
Highlighted
Stone_Database
Level: Powered On

Re: Help with appending a Sharepoint List (Create Item) from an Excel Table (List Rows Present...)

Hey I got it working!

 

I forgot to add the expression in the expressions area and hit "OK". That did work, for instance:

 

items('Apply_to_each_2')?['NetHandsetActivationsActual']

 

But, why is dynamic content not suggesting more than the first two? That would save a lot of time.

Community Support Team
Community Support Team

Re: Help with appending a Sharepoint List (Create Item) from an Excel Table (List Rows Present...)

Hi @Stone_Database,

 

Thanks for sharing and updating.

I am glad that you have figure it out and it is working for you now.

I found that sometimes we need to use the function items to get item from the previous actions. It is always working fine.

 

Best regards,

Mabel

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
firstImage

Power Platform Online Conference

Speakers, submit your sessions now! Call for speakers ends Feb. 10!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

firstImage

Incoming: New and improved badges!

We've given our badges an overhaul and also added some brand new ones!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,242)