cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KLD
Helper I
Helper I

How to test a Power Automate with a http request trigger in Postman?

I created a Power Automate with a http request trigger. In this http request action I have this json body:

 

 

{
    "type": "object",
    "properties": {
        "SiteUrl": {
            "type": "string"
        },
        "ListTitle": {
            "type": "string"
        },
        "ListGUID": {
            "type": [
                "string",
                "null"
            ]
        },
        "ItemID": {
            "type": [
                "integer",
                "null"
            ]
        },
        "ClaimsUser": {
            "type": [
                "string",
                "null"
            ]
        },
        "FlowName": {
            "type": [
                "string",
                "null"
            ]
        }
    }
}

 

 

 

I would like to test in Postman and try to do a Post request with this body:

 

 

{
  "SiteUrl": "https://myCompany.sharepoint.com/sites/Test/",
  "ListTitle": "Documenten",
  "ItemID": 60,
  "ClaimsUser": "i:0#.f|membership|svc-spo-dms-hi@myCompany.com",
  "FlowName": "Bestandsbeheer Documenten",
  "ListGUID": "4d084425-ff5a-4aa6-9227-51c42d820cec"
}

 

 

I got this error: The input body for trigger 'manual' of type 'Request' did not match its schema definition. Error details: 'Invalid type. Expected Object but got String. What I am doing wrong?

3 REPLIES 3
Expiscornovus
Super User II
Super User II

Hi @KLD

 

Just to double check. You are using the When a HTTP request is received trigger action, correct?

 

Can you also share a screenshot of your Postman setup, especially the body and the headers of your Postman request.

 

Btw, does your header of your Postman request include Content-Type:application/json?

I'm having the same issue.  I followed this precisely but still got the error mentioned above: https://carldesouza.com/triggering-a-microsoft-flow-post-request-from-postman/

 

Has anyone solved this?

MeatDepartment
New Member

Also encountered this issue.

Ensure the body is set to JSON not text

MeatDepartment_0-1614058652269.png

 

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (21,690)