cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Allie_B
Frequent Visitor

Hyperlink in Flow Message renders as plain text if message includes HTML styling

I have a Flow using the "Post a message as the Flow bot to a channel" action. The message includes a dynamic hyperlink to the selected file in SharePoint "itemUrl". The Flow posts a message successfully to Teams with a clickable hyperlink.

However, when I add HTML styling (color and font-size) to the message to draw channel members' attention, the hyperlink is rendered as plain text. Is there a way to have this flow's message with styled (large, color specified) to get viewers' attention AND for the file hyperlink to be clickable so they can go directly to the file to see it?

Flow without specified style on text:

StrongTextOnly.png

 Resulting message in Teams: clickable link:

ClickableLink-NoStyling.png

 Flow with specified style (font-size and font color):

Screen Shot 2021-01-12 at 5.01.36 PM.png

 Resulting message in Teams: plain text of the url.

Unclickablelink-Styled.png

1 ACCEPTED SOLUTION

Accepted Solutions
Allie_B
Frequent Visitor

I finally got it working! I rewrote it using the Post a Message (v3) action as you did. I think the key may have been immediately switching the </> button in the message editor on before adding any content.

Edit mode and results below.

Screen Shot 2021-01-13 at 4.54.13 PM.png

Screen Shot 2021-01-13 at 4.46.25 PM.png

 

View solution in original post

7 REPLIES 7
vhughes
Frequent Visitor

I want to say that this action does not accept HTML formatting, but uses Markdown: aka.ms/approvaldetails is a good resource with how it works, examples of syntax.

 

If they’re using HTML now, it maybe be an “all or nothing” issue. That, once you use your own, it doesn’t do anything automatically anymore. In which case: <a href=‘link’>link(or friendlier text)</a>

Allie_B
Frequent Visitor

Thanks for the markdown reference, @vhughes. The <a href = 'link'> format generates the Url but it is not clickable; it's just plain text. I also tried using the action "Post a Message (v3)" with same results.

 

vhughes
Frequent Visitor

I checked one of my flows that uses “Post a message v3” and realized it uses double quotes instead of single: 

C050D42D-C83A-40C8-A3B3-7E2D678A03A1.png

 careful not to put spaces around the equal sign

Allie_B
Frequent Visitor

Thanks again for the reply, @vhughes. I tried using the Post a Message (v3) action using the <a href=" "> formatting using double quotes and it just added double quotes around the plain text of the link referenced. Screen Shot 2021-01-13 at 2.01.22 PM.png

vhughes
Frequent Visitor

Hmm. Weird. Could you share a screen shot of the edit view of the action, please?

Allie_B
Frequent Visitor

I finally got it working! I rewrote it using the Post a Message (v3) action as you did. I think the key may have been immediately switching the </> button in the message editor on before adding any content.

Edit mode and results below.

Screen Shot 2021-01-13 at 4.54.13 PM.png

Screen Shot 2021-01-13 at 4.46.25 PM.png

 

vhughes
Frequent Visitor

Excellent! Woohoo!

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

New Ideas Forum MPA.jpg

A new place to submit your Ideas for Power Automate

Announcing a new way to share your feedback with the Power Automate Team.

MPA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

Learn to digitize and optimize business processes and connect all your applications to share data in real time.

Super User 2 - 2022 Congratulations 768x460.png

Welcome Super Users

The Super User program for 2022- Season 2 has kicked off!

Users online (3,149)