cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
UB400
Kudo Kingpin
Kudo Kingpin

I need to send e-mail alerts based on dates stored in Sharepoint lists

My apologies, I'm very new to Flow and am struggling even with the basics.

 

I have a PowerApps App that's using Sharepoint Lists as a Datasource. I need to send e-mail alerts if today's date = value of a Sharepoint List column called Alert Date, the Column in question is called "AlertDate" and is a Date only column.

 

If someone could kindly help with the code to compare the value of the above column with today's date, so I can then trigger the sending of an e-mail if the condition is true.

 

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
v-monli-msft
Community Support
Community Support

Hi @UB400,

 

1. In your flow, add a compose card.
2. In the Compose card, you can execute workflow functions specified here: https://docs.microsoft.com/en-us/azure/logic-apps/logic-apps-workflow-definition-language
3. An example to get today's date in the format of 2017-05-16, I would do: "@utcnow('yyyy-MM-dd')"

For example:

Capture.PNG

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
v-monli-msft
Community Support
Community Support

Hi @UB400,

 

1. In your flow, add a compose card.
2. In the Compose card, you can execute workflow functions specified here: https://docs.microsoft.com/en-us/azure/logic-apps/logic-apps-workflow-definition-language
3. An example to get today's date in the format of 2017-05-16, I would do: "@utcnow('yyyy-MM-dd')"

For example:

Capture.PNG

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

@v-monli-msftthank you for your response. i must be doing something wrong, when I test it doesn't work and when i try to send the value of @utcnow('yyyy-MM-dd') in an e-mail, instead of getting a value I get the text "@utcnow('yyyy-MM-dd')" instead.

 

Have a look at the image, I can't get it to work.

 

UTCCondition.jpg

You need to include the external double quotes exactly as posted by @v-monli-msft

Helpful resources

Announcements
Process Advisor

Introducing Process Advisor

Check out the new Process Advisor community forum board!

MPA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

Users online (99,728)