cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

I want my flow to send only one e-mail instead of two when a sharepoint item is modified

Hi Community!  

 

When a Sharepoint item is created or modified, I want flow to send an email to the individuals "Assigned To" and the "Oversight Mgr" I have Sally and Adam in the Assigned To and Benjamin as the OVersight Mgr. 

 

What this flow is doing:

1. Email 1: Sent to Sally and Benjamin

and

2. Email 2: Sent to Adam and Benjamin


What I want this flow to do is to send 1 e-mail to Sally, Adam, and Benjamin at the same time. 

 

Any help is very much appreciated! 

Capture.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

 

Hi @AHS20188 ,

 

Please try to refer to the following image to configure Flow.

182.PNG183.PNG

Hope this helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Super User III
Super User III

Hello @AHS20188

The reason you are getting multiple emails is because the send email action is inside the apply to each loop. For each item > send email.

You can get around this by using the send email action outside the loop.
However doing this does not let you reference any data inside the loop.

Check out my solution on this post:

https://powerusers.microsoft.com/t5/Building-Flows/Unable-to-reference-fields-outside-of-apply-to-ea...

It shows how you can reference data from inside the loop outside. So you can use your send email action outside the loops.

—Josh
If you like my post please hit the "Thumbs Up" -- If my post solved your issue please "Mark as a Solution" to help others




Did I answer your question? Mark my post as a solution!

If you like my post please hit the Thumbs Up


Proud to be a Flownaut!


Check out my blog for Power Automate tips, tricks, and guides
FlowAltDelete




Frequent Visitor

@Jcook Thank you, but that one isn't working for me.  Thanks helping though! 

Community Support
Community Support

 

Hi @AHS20188 ,

 

Please try to refer to the following image to configure Flow.

182.PNG183.PNG

Hope this helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

MPA Community Blog

Power Automate Community Blog

Check out the community blog page where you can find valuable learning material from community and product team members!

Top Solution Authors
Users online (9,243)