cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

Image attachments not displaying when uploaded to SharePoint.

 

Apologies if this has already been covered but I'm trying to set up a Flow that creates a SharePoint list item with the contents of an email and adds any attachments to the list item also.

 

I've got it to create the item with the email subject and body and attach any email attachments but the problem I'm having is that if the attachment is an image file (png, bmp etc), it fails to open.

 

I've read that it's to do with how the content data is saved but struggling to find a solution for SharePoint. Any help is greatly appreciated.

Failed to open.PNGFlow.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Image attachments not displaying when uploaded to SharePoint.

Hi @AaronRobinson,

 

Please make sure that the email contains an attachment and set the trigger to include the attachment to trigger, like:

24.PNG

Or you could determine if the email contains an attachment, and if it does, execute Add attachment action.

25.PNG

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

4 REPLIES 4
Highlighted
Community Support
Community Support

Re: Image attachments not displaying when uploaded to SharePoint.

Hi @AaronRobinson,

 

You could replace Dynamic content populated in File Content with Attachments Content.

Current Item contains all the information contained in the item, and the padding here is invalid.

Image reference:

1.PNG

Please take a try again.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Regular Visitor

Re: Image attachments not displaying when uploaded to SharePoint.

Hi Barry,


Thank you for your reply - I then receieve an error when I run the flow. Please see below.

FlowError.PNG

FlowError2.PNG

 

 

Highlighted
Community Support
Community Support

Re: Image attachments not displaying when uploaded to SharePoint.

Hi @AaronRobinson,

 

Please make sure that the email contains an attachment and set the trigger to include the attachment to trigger, like:

24.PNG

Or you could determine if the email contains an attachment, and if it does, execute Add attachment action.

25.PNG

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Regular Visitor

Re: Image attachments not displaying when uploaded to SharePoint.

Thanks Barry - it was the 'include attachments' option I was missing!

 

Apologies and thank you again! 🙂

Helpful resources

Announcements
firstImage

Super User Program Update

Three Super User rank tiers have been launched!

firstImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

Top Solution Authors
Users online (7,389)