cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AaronRobinson
Level: Power Up

Image attachments not displaying when uploaded to SharePoint.

 

Apologies if this has already been covered but I'm trying to set up a Flow that creates a SharePoint list item with the contents of an email and adds any attachments to the list item also.

 

I've got it to create the item with the email subject and body and attach any email attachments but the problem I'm having is that if the attachment is an image file (png, bmp etc), it fails to open.

 

I've read that it's to do with how the content data is saved but struggling to find a solution for SharePoint. Any help is greatly appreciated.

Failed to open.PNGFlow.PNG

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Image attachments not displaying when uploaded to SharePoint.

Hi @AaronRobinson,

 

Please make sure that the email contains an attachment and set the trigger to include the attachment to trigger, like:

24.PNG

Or you could determine if the email contains an attachment, and if it does, execute Add attachment action.

25.PNG

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
4 REPLIES 4
Community Support Team
Community Support Team

Re: Image attachments not displaying when uploaded to SharePoint.

Hi @AaronRobinson,

 

You could replace Dynamic content populated in File Content with Attachments Content.

Current Item contains all the information contained in the item, and the padding here is invalid.

Image reference:

1.PNG

Please take a try again.

 

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
AaronRobinson
Level: Power Up

Re: Image attachments not displaying when uploaded to SharePoint.

Hi Barry,


Thank you for your reply - I then receieve an error when I run the flow. Please see below.

FlowError.PNG

FlowError2.PNG

 

 

Community Support Team
Community Support Team

Re: Image attachments not displaying when uploaded to SharePoint.

Hi @AaronRobinson,

 

Please make sure that the email contains an attachment and set the trigger to include the attachment to trigger, like:

24.PNG

Or you could determine if the email contains an attachment, and if it does, execute Add attachment action.

25.PNG

Best Regards,

Barry

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
AaronRobinson
Level: Power Up

Re: Image attachments not displaying when uploaded to SharePoint.

Thanks Barry - it was the 'include attachments' option I was missing!

 

Apologies and thank you again! Smiley Happy

Helpful resources

Announcements
firstImage

Microsoft Business Applications Virtual Launch Event

Join us for an in-depth look at the new innovations across Dynamics 365 and the Microsoft Power Platform.

firstImage

Watch Sessions On Demand!

Continue your learning in our online communities.

Power Platform 2019 Release Wave 2 Plan

Power Platform 2019 Release Wave 2 Plan

Features releasing from October 2019 through March 2020

thirdimage

Flow Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Flow Community Video Gallery!

Top Kudoed Authors
Users Online
Currently online: 226 members 4,637 guests
Please welcome our newest community members: