cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
David_MA
Impactful Individual
Impactful Individual

Instant Cloud Flow Fails with Attachment from Folder but not Camera

I have an instant cloud flow that we run on mobile devices, which includes an attachment field. If the user takes a picture with their camera, the flow runs without any issues and sends an e-mail with the included attachment. However, if the photo is uploaded from a folder, the flow fails. We only use iPhones for our company devices. Has anyone encountered this behavior?

1 ACCEPTED SOLUTION

Accepted Solutions
David_MA
Impactful Individual
Impactful Individual

A little more digging around on the internet, I solved the problem. Since we use iPhones, the images are saved in HEIC format. To resolve this I needed to add base64ToBinary() to my attachment content string. 

 

base64ToBinary(triggerBody()['file']['contentBytes'])

 

View solution in original post

2 REPLIES 2
David_MA
Impactful Individual
Impactful Individual

A little more digging around on the internet, I solved the problem. Since we use iPhones, the images are saved in HEIC format. To resolve this I needed to add base64ToBinary() to my attachment content string. 

 

base64ToBinary(triggerBody()['file']['contentBytes'])

 

v-xiaochen-msft
Community Support
Community Support

Hi @David_MA ,

 

Glad to see you resolved the issue.

Please consider marking your own reply as a solution.

 

Best Regards,

Wearsky

Helpful resources

Announcements
Power Automate News & Announcements

Power Automate News & Announcements

Keep up to date with current events and community announcements in the Power Automate community.

Community Calls Conversations

Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Automate Community Blog

Power Automate Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (4,537)