cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Newbie_SP
Level: Powered On

Invalid Template Error

Hi

My approval flow was working until I entered the information into the Details section of the Start and Wait for Approval.

 

I am at a loss of what I have done wrong. As the user name suggests, I'm a newbie....

 

Any help greatly appreciated

 

Cheers

 

Flow.JPGInvalid Template.JPG

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Invalid Template Error

 

Hi @Newbie_SP ,

 

If the Approval action is in Apply to each, if you want to reference the Dynamic content output by this action, you need to configure the remaining actions in Apply to each.

 

What you need to consider here is how to reference the Leave type value. This seems to be a choice type field. It is recommended to use the following method to get the leave type value, then reconfigure the Approval action and configure it outside of Apply to each.

 

Like:

3.PNG4.PNG

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: Invalid Template Error

 

Hi @Newbie_SP ,

 

If the Approval action is in Apply to each, if you want to reference the Dynamic content output by this action, you need to configure the remaining actions in Apply to each.

 

What you need to consider here is how to reference the Leave type value. This seems to be a choice type field. It is recommended to use the following method to get the leave type value, then reconfigure the Approval action and configure it outside of Apply to each.

 

Like:

3.PNG4.PNG

Hope it helps.

 

Best Regards,

Community Support Team _ Barry
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Newbie_SP
Level: Powered On

Re: Invalid Template Error

Hi. Thanks for the reply. I managed to backtrack a little and realised that the Leave Type column in my list had been set to Multiple choice. So changed that and now the flow works. Thanks for your assistance and patience.

 

Cheers 

Helpful resources

Announcements
firstImage

Incoming: New and improved badges!

Look out for new contribution recognition badges coming SOON!

firstImage

Power Platform Online Conference

Join us for the first ever Power Platform Online Conference!

firstImage

New & Improved Power Automate Community Cookbook

We've updated and improved the layout and uploading format of the Power Automate Cookbook!

thirdimage

Power Automate Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

fifthimage

Microsoft Learn

Learn how to build the business apps that you need.

sixthImage

Power Platform World Tour

Find out where you can attend!

seventhimage

Webinars & Video Gallery

Watch & learn from the Power Automate Community Video Gallery!

Top Solution Authors
Top Kudoed Authors
Users online (5,537)