cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Invalid Template for action 'Condition'

I am new to Flow and normally create approvals via Designer custom WF so I thought I'd try a simple approval template flow, the approval component mechanism works correctly but when it comes to utilise the approval decision the template cannot execute to perform the Yes and No actions.

The condition is default from the template

2019-03-22_15-03.jpg

 

 

 

 

 

 



The Error

2019-03-22_14-58.jpg

1 ACCEPTED SOLUTION

Accepted Solutions
v-zhos-msft
Solution Sage
Solution Sage

Hi @Anonymous ,

Which template did you try?
Could please share a full screenshot of the flow?
As the error message said, the return of 'Response' is an array, so you need a index to the code.

Please take a try of the code below instead of the Dynamic content of 'Response':

body('Start_an_approval')?[0]?['response']

However,the template was still use the old action of Approval connector.

There are some update of the 'Approval' connector, So I don't recommend you to use the template.

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

2 REPLIES 2
v-zhos-msft
Solution Sage
Solution Sage

Hi @Anonymous ,

Which template did you try?
Could please share a full screenshot of the flow?
As the error message said, the return of 'Response' is an array, so you need a index to the code.

Please take a try of the code below instead of the Dynamic content of 'Response':

body('Start_an_approval')?[0]?['response']

However,the template was still use the old action of Approval connector.

There are some update of the 'Approval' connector, So I don't recommend you to use the template.

Best Regards,

Community Support Team _ Zhongys

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

 

View solution in original post

Anonymous
Not applicable

Thanks for checking in, now that I've had a chance to dig deeper into our environment it seems that as we do not have CDS enabled and are not looking to do so which means there are a number of things not working as they should and this approval connector being one of them. I've having to go back and locate a new approval connector that doesn't utilise CDS. If you have any thoughts on what this connector might be let me know.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Microsoft Ignite 768x460.png

Find your focus

Explore the latest tools,training sessions,technical expertise, networking and more.

Top Solution Authors
Users online (2,397)